Clip Zip - can't get to the menu

I’ve been a happy Clip Zip user for three years. This morning, I wanted to listen to an audiobook. I pressed the arrow button on the top left-hand corner but the screen only showed the first song in Music. Now I can’t go to the menu and can only scroll songs in order.

I tried rebooting and downloading the lastest software but nothing has changed. Any advice?

Hi. Looks like this is still unanswered for you. Have you tried soft and hard reset respectively? 

@hirsche wrote:

Have you tried soft and hard reset respectively? 

Why don’t YOU explain what a _ soft _ and hard reset are, and how to perform them? Since there is only ONE reset procedure, I’d be interested in what you have to say regarding that.

Don’t mean to be rude here, but I for one am getting real tired of your multiple aliases, bad advice, not reading posts before replying to them, and irrelevant qustions on this forum.

Many forums have rules against posting under different names, and if this one did, you would have been banned long ago. You are NOT contributing to this community with all this nonsense, so please

http://us.cdn4.123rf.com/168nwm/moby/moby1008/moby100800004/7529290-stop-it--stop-sign.jpg

:angry:

I’m thinking it’s time to buy a new Sansa MP3 player… 2-3 years of constant use isn’t bad. I might take the music off this one as just use it for audiobooks.

Repeatedly pressing the HOME button doesn’t get you back to the Main menu? It may not help, but it can’t hurt to update (or re-apply) the firmware; maybe there’s something afoul there.