clip wont turn on at all

I have the Sandisk 2gb clip.  Have had about 8 months.  Charge alwayhs with comp usb connector.  Few days ago, it simply stopped turning on.   Had it working even that morning.  I am 100% positive that NOTHING could have happened to it, damage, cold, water spills, etc.  It connects to my computer and it recognizes it,but I also cannot copy music–it says WMP cannot access file, might be in use, might not hav e access to comp where fiel stored or proxy settings might not be correct. , I can copy music to it, I’ve updated firmware, still no change.  When it had stopped workign I had not addedany new content that might have bugged it, etc.  I had been using whatever firm where it came with when it died.

–had sansa for about 8 months, always worked fine.  sometimes weird file types wouldnt copy or play, but otherwise liek a dream.  2gb sandisk, always charged by comp cable

–few days ago stopped working.  will not turn on.  have tried charging to full capacity, holding on button for many seconds…no luck. 

–next tried updating firm ware, said it did it???.  next deleted everything off the entire disk, total blank.  tried to update firmware, it failed, tried agian and it wet through;

–still will not turn on.   Currently showing V01.01.18  when i click from my computer

Please help, I love my toy and want it working again!  I am positive there is nothing I did to break it

Philip Blake


followup–comparing the firmware # vs teh version # my comp says it sounds like its not updating it, it just keeps dowloading isntalling saying its done and then asking me to update again.  But i still want to know why my baby stopped working for no reason in the first place.

Did you try a reset? Hold the powerslide on for minimum 10 seconds. Make sure you never diconnect while data is being transferred. That will give you the nasty dark screen every time.

I should have read closer…you tried that. When mine did the same thing I had to force it open in another protocol. MTP driver got bugged on my machine. It would open on my laptop sometimes but then just went dark. I did a full re-do, drivers firmwarte and protocal change…instructions are in the FAQ section on Sansa support. Works fine now, except for the cheesy earbud wire broke inside the casing last night…limping on one ear now until I get a replacement

see taht…but i cant turn the **bleep** thing on so cant do the MSP thing, and even when its ocnnected to computer and shows the connection as good(and appears in my comp) the firmware for whatever reason will not let itself update.

 does sansa do exchanges for upgrades?  send them this thing and 50 bux and get the newer model or anything like that?