Clip won't turn on...

I have a 2 gb clip which worked just fine until recently. I got a lot of viruses and had to wipe my hard drive. When I plugged the sansa into the computer, it wouldn’t show up in my computer. Someone recommended I put the slider in the hold position and hold the center button while plugging it in and now it won’t turn on at all, nor is it recognized by the computer. What should I do?

The Clip never sleeps, it simply freezes.  Slide the power switch to the ON position, and hold it there fir about 20 seconds to reset the device.  Release the switch, then try powering up as usual.

Bob  :smileyvery-happy:


I, too, would like to know what the next step is when the 20 second hold approach doesn’t work. Thanks.

I found that sliding the switch to the on button and simmultaneously pressing the voulme button on the side worked for me. I was just on this website searching for answers because my sansa 8Gb wouldn’t work. I took the advice of holding the switch for 20secs and upon accidentally touching the voulume button at the same time, the darn thing started working? hmm? Its worth a shot.

My 2GB clip is also not turning on and I have tried 10 sec, 15 sec, 10 sec, holding the middle button, holding the volume simultaneously, I’ve tried every solution I have found and it is still not working.  It charges on the computer, but it will not power on.  This is only 4  months old so I am not happy about this.  HELP!!

Having the same exact problem with my sons clip. IT was working a few days ago and now nothing. It is not even 5 months old. I have tried eveything. Mine won’t even turn on if you plug it into charge! There is NOTHING???