Clip+ stops power-up at flower

I have two Clip+ units, the second of which I was keeping “in reserve” since I like the Clip+ so much.  The first developed problems, viz., the earbud jack needs to be resoldered, so I broke out my spare.

I loaded mp3 files on it and changed some folder names in the process.  When I disconnected it from the USB connection, it appeared to restart, but then stopped at the flower-like image which comes immediately after the SanDisk name.  There it stays.

Nothing I have tried gets it past that point.  I have tried holding the power button, tried pressing the home key and power button (simultaneously, one before the other), tried pressing other keys alone or in combination, but nothing.  It just looks like it is stuck in a software loop.

I have opened the case and was hoping that there was some way to reset the unit internally or wipe the memory and restart.  So far I can find nothing useful.

Any suggestions would be appreciated.

Something in one of your changed folders is probably stopping the Clip at bootup.

Try CHKDSK to fix disk errors, and if that doesn’t work, Format it to wipe off your material and start over.

Turn it off. Plug the USB cord into your computer. Hold down the center button while connecting to your computer (which forces it to connect in MSC mode and shows it to your computer like two disc drives: Sansa Clip and the card slot). In Windows (Computer or My Computer), right-click on the SANSA CLIP drive and go to Properties/Tools and Disk Checking. Tell it to fix errors it finds, let it check. 

If it still doesn’t boot after that, Format it (which will not remove the Clip firmware, just your files). Connect while holding the center botton, right-click and Format from WIndows. That will wipe the memory.


Thanks for taking the time to reply.

I have tried your suggestion to no avail.  No matter what I do, my Clip+ comes on, show the flower, blanks the screen, and then shows the flower continuously.  I simply cannot connect to it from my Windows 10 computer in any manner.

The files I added had folders with long names.  I am guessing that that caused the initial problem.  It seems that I need some way to delete those folders in the Music directory.  I have even considered opening the unit to see if the memory chip(s) were obvious hoping I could find some data to erase it.

Any ideas?

This is a brand new unit which I specifically purchased to have a spare.  My original still works, but I need to re-solder the headphone jack to the board (again!).


I am in the same boat, and this is also a new “spare” that I gave to my wife to use. Don’t know what she loaded onto it for files but it does exactly the same thing, stuck on boot with the flower icon. The player is not recognized by the computer so can’t see or access anything on it. Tried the suggestion of holding in the center button while connecting to the computer but no go…just starts to boot and then stops at the flower.

This is a new player and I really would like to get this fixed so it is more than a useless technology paperweight.  Any help would be GREATLY appreciated!


I have the same exact problem. It gets stuck at the flower logo and is not recognized by my PC. No combo of button pressing has worked. I even tried opening it up to see if there was an obvious mechanical problem but couldn’t tell. So I guess there’s no solution for this?