I’ve had my Sandisk clip for about 3 years.

Have had several times I had to reset it to get it to work.

I have already ordered a new one, but need to delete my old player off of my audibles account.

I keep trying to reset it but it won’t boot up past the flower image.

It first shows sansa then it goes to that flower image and won’t go any farther.

Any ideas?  I need to at least plug it in one last time to my audibles account to delete the device.

Can it connect to your computer? Try plugging it in with the player off and holding the REW button. If so, manually re-install the firmware.

1 Like

When I plug it into my computer, it doesn’t recognize anything is plugged in and the mp3 won’t do anything at all after reset.

Try a different cord. And have you tried connecting while you hold down the << button or the center button.


Glad I’ve found this thread as I have the same problem.

I’ve had four Sansa Clip+ players during the last 5 or 6 years - my wife uses one for audiobooks, I have one in my van and one in the kitchen plus a spare I bought when I read that Sandisk were ditching the Clip+ a few years back but for the last few weeks one of them has frozen on startup and won’t go any further.

The startup display sequence is Sansa - Flower image - Sansa - Flower image… and that’s it, just freezes - and it’s not recognised by my laptop.

Is there some sort of button combination on startup that might get over this problem? Or is there another solution I can try?

I’ve read the answers to the original poster in this thread but the suggestions haven’t worked on my device.

Would love to get it working again.


Dave W