Clip plus died ?


I have a Sansa Clip plus and it has just stopped working (after about 6 months’ use. It hasn’t received any physical trauma).  

MS Windows can see it fine, but when I try to turn it on,  the screen is blank blank blank.  Same goes when I plug it into a mains charger - the device shows nothing on the screen.  I have tested the charger on other devices and the charger is fine.

I guess that either the screen or battery is kaput.

Is there anything I can do ?    I tried the autofirmware software update, but it hung on clicking the ‘finish’ button.  


btw, I have tried holding down the start button for 45 seconds and also all combinations of “Start+other” buttons

tried all of these :

It is Rockboxed (v1.3.1), but has been fine that way for 6 months. . .

I have ‘trickle charged’ it on mains for about 14 hours, but I’m on the road and won’t get access for 24x7 elelctricity for a while now. 

It might be a hardware display issue but I think this does come with a 12 month warranty. Have you tried to check this yet? 

You might try manually reapplying the latest firmware (see the firmware sticky thread in this forum) and/or manually reformatting the player using Windows (note that this will erase your user content on the player–transfer anything you want to save to your computer first).

My fear, though, is that this is a hardware failure.  You may need to contact SanDisk for a warranty replacement.