Clip not working - Have tried everything (hopefully not)


I’ve been browsing various threads on this forum while trying to fix my Sandisk Clip, but with no luck.

It stopped working suddenly one day, it will only show the Sandisk logo when trying to power it up. Sometimes it will show the refresh database screen and hang there, indicating that it may be that issue. I’m using Vista 32bit btw.

Here’s a little summary of things I’ve tried and effects:

  1. Normal usb connect doesn’t work. it shows as two drives when connected, both F: and I:, and at the same time windows tells me to format it. Drives acts as unformatted ones should.

  2. Format doesn’t work, neither from windows interface or the cmd command. It can’t write to the disk. If it do it in MSC mode, it will idle for a few minutes before giving an error.

  3. It will register in MSC mode. I can view my files, but I can’t delete or add.

  4. Updater doesn’t seem to detect it. Last time I updated the firmware was two months ago I think.

  5. Holding power-button up for 15sec does nothing.

I really hope there’s something I’ve missed or that someone knows a magic trick for it.


Message Edited by Shinia on 10-07-2008 12:12 PM



Seems it decided to partly show while connected normally (it didn’t really do that before it bugged either…) I don’t see it as a drive, but under “Portable devices” when browsing my computer. It also doesn’t show my actual folder content (which is does in MSC mode), but I could format… It said the format was complete after one second, so probably bugged. Also now the updater was able to detect it and wanted to install the latest firmware! But it failed at start of install :frowning:

If you can connect, can you manually update the firmware?  See the sticky thread at the top of the forum.  I’m hoping that might remedy things.

I have tried that and only get an error that it can’t write to disk.

Vista has found your Clip and reinstalled it into the Matrix.

On the Clip, you have switched to MTP mode somehow.  This is why it is showing under “other” as a media device.

Manually switch back to MSC mode (where you loaded your music), and plug in again.  Does the Clip show up as two drives again?  If you have a Micro-SD socket in your Clip, I’ll trade mine with you, as that would be interesting.  There’s something amiss in Hoboken, as Vista is seeing a bit that it shouldn’t- the expansion capability (the same processor has µSD enabled on the Fuze and v2).

If the Clip shows up on your PC, let it charge for a wee bit, and then unplug.  Use the Clip’s onboard Format command (Settings > Format > Yes) to clear the device.  Then plug in, and install the latest firmware, via this thread.

Be sure to use the manual firmware installation mode (for simplicity’s sake), and unzip the firmware file before loading in the root directory box.

Let us know how it goes!   Hopefully, the siamese twin memory will be reset to normal!


Bob, I would fight you for it if it had micro sd!!! :smileyvery-happy:

Although there’s a big problem in using the clip’s onboard format command, as I can’t turn it on. It freezes on the screen where it says “Sandisk”, and it freezes during “refresh database” whenever I unplug it.

Connect to your PC in MSC mode.

First, open a Windows Explorer browser, by clicking on My Computer, or holding the Windows key and the E key together.

Start with the Clip OFF.  Slide the power switch down to the HOLD / LOCK position.  Hold the center button down while connecting to the PC.  In your Explorer window, the Clip should appear.

It will be given a drive letter.  Make note of this letter.

The freeze during Refresh Database is a sign of a corrupted file messing with the database generation process.  Let’s eliminate the file corruption end of the equation first.

Click Run > enter cmd and then the enter key.  An MS-DOS command prompt should pop up in a black screen window.  Enter chkdsk X: /f where X: is the drive letter of the Clip in the Explorer window.  When it asks if you would like to save the data found, discard it.

Slide the power switch back to the center position, unplug your Clip, and see if it goes through the refresh database normally.

The next thing that can cause issues is the tags on your music, the ID3 tags.  For this, I recommend MP3Tag , a free utility, that will check and repair your tags.  You will need to set the tag type to ID3v2.3 ISO 8859-1.

The best thing to do (simplest) is first restore your Clip to normal operation.  Thsi involves formatting the memory in the device to clear the troublesome data.  Note that this erases all of your music on the device.

All you need do is connect again in MSC mode as above, and the Clip will reappear in the Explorer window.  Right click on the device and select Format.  Do not use the “quick format” command, but the basic mode.

When you unplug, the Clip should be back to normal.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 10-12-2008 08:52 PM

I followed the instructions, but still no luck. The checkdisk executed ok but didn’t seem to do much, and then the clip froze as usual after I unplugged it. Now for the format… After connecting in MSC mode and selecting the default non-quick format, it stood idle doing nothing for maybe a minute, and then gave the error "Windows was unable to complete the format.

I have the same issue… have tried everything… even tried to delete the partition in Linux. The clip will not allow any kind of changes (writing) to it… every thing fails… did you find a solution for yours?