Cannot Format Clip

Hello, I am hoping someone helps me.  I have tried all the things I have found on the board so far.  I have a clip that will not let me write any files, not update the firmware, not reformat it from its own menu or from Windows.  I have tried the force the format in MSC mode but it gets to the end of the format and says it cannot complete it.  When formatting from its own menu it seems to blank everything, but the free space does not change and after turning the device off and back on everything is still there.

Does anyone have any other ideas?  TIA-ACS

I’m using the Clip under Linux OS.

From factory the partition table as it was seen by Linux was corrupted, although the player seemed to like it just fine.

So I zeroed the first MB of the Clip with dd (dd if=/dev/zero of=/dev/sdx1 bs=1M count=1), then I used cfdisk to create a partition type 0c (win95 fat32), and formatted that with mkfs.vfat.

The Clip then re-creates it’s database files and standard directory structure on that partition.

Please note that I used this procedure on a brand new clip, which already came with the latest firmware available.

I am using Windows XP SP3.  Do you think this command would work there?  What would I do, go out to the shell and switch to the clip drive then issue that dd command?  I also don’t know what cfdisk and mkfs.vfat are.  Are these commands too?  Sorry, you obviously know a lot more about formatting drives than I do.  Is there a way for me to check if my partition is corrupted?  ACS

Unfortunately I can not speak very well for Windows because I use windows for gaming only.

However from what I gather from other threads / faqs in this forum, Windows has two different modes of accessing data on the Clip.

One is MTP (Music Transfer Protocol), which gives you access to music files on your clip, but no access to the actual partitions of the clip, i.e. you can not format in this mode.

The other is MSC (Mass Storage Class), which is also what I use under Linux (although it’s called USB Mass Storage there). It allows you direct access to the Clips storage (like USB Stick) and allows formatting.

Maybe this is actually your problem?

I’m sorry, you already said you were using the MSC class. It seems that I’m just confusing everyone today… if you have a little experience with Linux you could boot any Linux live CD. However you should not use those commands if you don’t know what you are doing, as you may end up losing your hard drive data if you use the wrong device.

I have connected it in both ways and have tried to format it in MSC mode.  That is where it seems to be working and then says it cannot complete the format.  Hmm I am wondering if I look at the disk performance utility if I could see this clip drive and get it to tell me more about it.  Maybe I will try that.

Hi alzheimer

I use Window and when I try to format it just give me an error at the end. I went into Linux and try to format with GParted and even so it finish saying OK, when I went back to Windows all the contents were there. I can not delete the songs I have in it which I thing are giving the problem of freezing the sansa clip when refreshing the database.

I will appreciate if you could give me step by step instructions of how you “zeroed the first MB” and so on.

Thanks in advance

Message Edited by monin13 on 02-05-2009 07:14 AM

Howdy all you music lovers,

I fixed my Ver.1 2 Gig Clip by doing the following computer based format /partition/firmware install…

(my original format operation did not work until I set Partition type to MBR, see note below)

On a PC:

  • Connect in MSC mode.
  • Right-click on your player in Windows Explorer.
  • Select Format… from the context menu.
  • Make sure it set for file system FAT32 (should be on by default, but check anyway).
  • Do Not select the “Quick Format” option.
  • Make sure the partition map type is set to"Master Boot Record"!
  • IMPORTANT NOTE: if the partition type is set to “GUID Partition Table” or “Apple Partition Map”, instead of MBR (Master Boot Record), The Clip will power up with error message:

“Not Enough Space for music DB, Please Free 30MB”

and then it turns itself off

  • Click the Start button.
  • Verify that this is what you want to do and click OK.

With an Apple Intel MacBook laptop running OS 10.5.6, I was able to restore my Clip to normal with the Disk Utility and the settings below.

  • Connect in MSC mode.
  • In Disk Utility (located in the Utilities folder in the Applications folder),
  • Click on(highlight) the 1.9 GB SanDisk Sansa Clip   2GB Media" located on the left side.
  •  click on the “Partition” tab on the upper right side.
  •  select “1 partition” from the “Volume Scheme” drop down menu.
  •  select MS-DOS (FAT) from the Format drop down menu.
  • click on the “Options” button near the bottom center.
  • Select “Master Boot Record” MBR partition scheme and click OK.
  • double check that you are formatting the Clip (and not your hard disk)
  • click on the “Apply” button in the lower right corner.
  • When formatting /partitioning is complete, copy the m300a.bin firmware update file  ( ) to the clip ,
  • eject, disconnect and the clip should reboot, install the firmware update and begin working properly again.
  • now move your music files to the clip and have fun!

Formatting will only delete/erase content put on by you, the user. It will not erase the firmware or any needed operating files, so it is safe. You will have to reload all of your music, etc. tho, it shouldn’t take long. :smiley:

Hope this helps some of you out there who have “Bricked Up” Clips , get back in the mix.

Happy Trails

I have the EXACT same problem with my sansa clip… i’m pulling my hair out…

 - Can’t format

  • can’t delete anything

can’t add/remove anything

Format in windows = error

Format in WMP11 = complete (nothing happens though)

Format in player = turn itself off and loads up again with all the old music

Reset does nothing

i’m using 1.0.29 firmware, i’ve tried practically everything suggested

this thing really doesn’t like windows, I’m using SP3 btw and WMP11…

it’s a joke to be honest