Clip will not allow me to load music, delete music, or reformat regardless of mode its in??

Firmware update process froze and failed so i have a strange issue with my Clip. For playback the unit functions normally, all the music that was loaded before the failed update can be played, (although it tries to refresh the database on every boot for a few seconds) Here is what i have tried… Formatting the unit from the unit… says complete…but lies… all the songs are still there. tried -checkdisk and format in every mode connected to PC, actually have tried on multiple PCs one XP and one Vista. I even tried to delete and/or format in Linux. The bottom line is the unit will not allow any changes to the memory regardless to method. I cant even delete files in the unit, from the unit… (it allows me to but when i reboot it they are back)

Seems to be write protected somehow… it looks like a few others have had a similar problem with no fixes so far… anyone have any ideas? 

Thanks,

Dan 

If it is new, I’d take/send it back and get another one. Sounds like you’ve done everything you can.

Any solutions for this? this is what i am now suffering with…

Change to MSC mode on the player and have another go at it.:smiley: