Cannot format the device

Just got an error from Windows telling me it could not complete the format of the device. The device still says Writing…but the format apparently failed.

Why are you trying to format?  And did you try format under the Clip’s settings?

I am have the same issue. It started that I couldn’t get any files to transfer to the device. So attempt to format via the menu on the Clip which completed and showed now data on the device anymore. When I power off and back on, it shows all the data and I was able to play the files. I then tried formating via Windows Media Player  (10) and had the same described here… Clips displays “Writing” while the PC says it “Complete” but clicking OK causes Media Player to locks up.

Forcing a reboot of the Clip it still shows all the music, I can play the media, but my Playlists are empty. Under Windows Explorer, the device list the top level folders (i.e. Music, Albums, Playlist, etc…) but no data in them. Media Player still shows all the files as being on the device. And I am still unable to Sync with the device or drag-and-drop to it. And I can not delete sing from the device either

Sorry to butt in but I have the same error/problem so I was wondering if you ever found out what is causing it and how to work around it?

format the clip in “force-msc” if losing all data stored in it is not an issue for you. to do force-msc, make sure its NOT connected to pc, turn it off, put the power switch to hold position, press/hold select(center) button while connecting it pc, dont let go until pc recognizes it. it might appear under my computer window as either of these 2, m350(for a 2gb) or m340(for a 1gb). right-click on it, left click format, inside format window leave everything in default, DONT check quick format, click ok/start. once finish, unplug it. move the switch to normal(either middle or up) plug it back to pc. now sync the songs.

Thanks! :o)

I did not care about the data but could not get the d@mn thing to format - this worked! :smiley:

very good! good luck to you… :smileyvery-happy:

i try your help to format the clip, but i doesnt work.

windows saying: i couldnt comlete the format.

have anybody any idea? thanks a lot

Format from the Clip’s Settings–there’s an option there, on the Clip player itself.

I know the option in the settings, but i got exactly the same problem like the guys on top.

when i formatted and startup the player again, its not empty. i cant upload songs, i cant delete songs, i cant format.

i just can hear my music and load the accu. i hear the same songs since 8 mont, this is boring.

i must reset the player or i throw it in the trash.

so please help me!

Did you try a reset?  With the Clip off, hold the on switch uppermost for 15-20 seconds.

Absent that, I would telephone SanDisk Customer Service and see what they can do for you, or get a 1-year warranty replacement.

@miikerman wrote:


Absent that, _ I would telephone SanDisk Customer Service and see what they can do for you, or get a 1-year warranty replacement. _

2nd that.

Yes, i try the reset and it dont works.

For sure the warranty is the best idea, but i got the player much longer than one year. So no warranty for me.

I check the hotline later and see what they can do.

So far, thanks a lot.