Clip+ erroring on Audible files in Audible Manager

HELP!!! I just purchased a 2GB Clip+ and love it! I finally figured out how to load & listen to music from my 4 GB SDHC card (thanks to this forum). The only issue I have yet to conquer is that I can’t get Audible Manager to load my audiobooks. It recognizes the Clip+, but when I try to load a file, it gives me an error message stating: Device specific error; unable to update your device.

I found a thread regarding this error with suggestions for a Clip - which I tried, but it didn’t work. Is there something different I should do for a Clip+?

I have updated my firmware, reformatted my Clip+, deactivated and reactivated the device in AM, but I still get the same error. I have the USB set to MSC (but I’ve also tried it in MTP). I working on a laptop running Vista.

If anyone can help me I’d be eternally grateful! My SanDisk e130 has completely bit the dust and I really want to load them on to my Clip+.

What is the formate of book that you are loading to the Sansa Clip+? (Format 2,3,4 or e)

I had a problem loading a book into a Creative Zen. The format was wrong. On the right side of the Audible manager page, the book discription should list the format type. And on the bottom right the player should be shown with the space remaining. I had to redownload a book in the proper format. Please post your findings. Mark S.

This might help

Audible formats

Audible has been in serious trouble with their software for the last two weeks.  Download manager is one of the problems.

Call their tech support at 1-888-283-5051.  They should be able to walk you though the problem.

Donna in AR

All my files are in format 4.

@bnanai wrote:

It recognizes the Clip+, but when I try to load a file, it gives me an error message stating: Device specific error; unable to update your device.



Format 4 should work with your Clip+. This could be caused by your firewall blocking the update. This link might help.

Thanks for all the suggestions. I tried fixing my firewall settings, restarted my laptop, re-formatted, deactivated & reactivated my Clip and I still get the same error. I’ll try calling Audible support tomorrow and let you all know the outcome.

In one last attempt, I tried moving my audiobooks to my Clip+ in Windows Explorer.  (This did not work in the past.) SUCCESS!!! I’ve wasted far too much time with Audible Manager and since Donna was kind enough to let me know that they’ve been experiencing problems across the board for the past couple of weeks, I’m not going to waste any more time on it. My Clip+ is now loaded and ready to go.

Thank you all for your help. I’m not sure which solution fixed the problem, but it’s working great now.

Good to hear it’s working now. :smiley:

I have had my clip+ for several weeks now, and really like it a lot for books (I keep no music on it at all). I could swear that after I first got it, I loaded an Enhanced book via Audible Manager fine, no problem at all. However … when I tried again today, the Manager just hung, with a sort of error message. I deleted and re-installed the software - same thing! Then I tried transferring the Enhanced file via Windows Media Player, which worked perfectly; it played, I exited the file to listen to something else as a test, and it offered to resume at the left-off spot when I returned to the Enhanced book. Then, when I plugged in my Clip+ to see whether AudibleManager would at least recognize the book, the software froze up again!

I’m willing to transfer my stuff with WMP, but wanted to know if others had Enhanced issues, too?