Cant see my music

I already loaded songs on my Sansa Clip, the PC does not see the files on it…  I am using Windows Vista.  I do see the Sansa in the files, and I see the sub folder MUSIC, but I cant see the music files, but they are there.  


There are two USB modes you can transfer files in: MTP and MSC (there’s a third option on Sansa players, “Auto-detect”, but that just automatically selects either MTP or MSC depending on whether working MTP drivers are present on your PC. MTP is part of Windows Media Player 10 and up). Files loaded in one mode can’t be seen by your PC while connected in the other mode, but your Sansa will see all files loaded in either mode. This is normal. You probably loaded files in one mode and are now connected in the other, possibly because “auto-de f ect” (as it’s commonly known around here) decided to change modes for some reason.

And, that’s a good reason to avoid using the Auto setting and to trying to use MSC mode or MTP mode consistently.

Uhm… how do I change modes ?

Got it guys, thanks.   I read the other posts…  good to go.