cant see files in folder in Pc in msc mode

hi

My PC dont recognise sansa clip now… it was working fine for months

i even did firwmware upgdare but no effect 

when i connect it to my PC i found that sansa shows connect but it doesnt charge and i also dont see it my computer

so i changed setting to MSC mode … then my sansa started charging and it showes as like a pen drive in MY Computer but now I DONT SEE MY MP3 FILES  IN THE MUSIC FOLDER

the files are there when i switch on my sansa

also when i charge using adpter it charges normally 

pls help … what do i do … how do i view my files …

This problem has been beaten to death. You can’t see the files in MSC mode if they were downloaded in MTP mode and vis-a-versa. I’ve no idea why it wouldn’t charge. It doesn’t show up as a device in winxp if in MTP mode, you need to use WMP or Rhapsordy. You don’t say how you were accessing previously but I assume that no longer works.

@dave61430 wrote:
This problem has been beaten to death. You can’t see the files in MSC mode if they were downloaded in MTP mode and vis-a-versa. I’ve no idea why it wouldn’t charge. It doesn’t show up as a device in winxp if in MTP mode, you need to use WMP or Rhapsordy. You don’t say how you were accessing previously but I assume that no longer works.

ya i dont see sansa clip as a device in xp now… 

i wss accessinf files normally bfore, just plug usb and a sansa icons comes and i see folders … but its not working now

NOW I VE JUST FOUND OUT A SOLUTION

 

when i plug it in usb … it shows message but doesnt show in My computer but sansa shows connected but not charging ( isee that many prople have same problem in forum so i posted my solution) then i clicked that harware icon which comes in taskbar just when u plug … then i click sansa and then UPDATE DRIVER … then it shows MTP device and come file transfer type icons and then my device back to normal as i see sansa icon comes back :) 

Great, and thanks for posting the solution for others!

I don’t see an icon in the task bar (MTP Mode). I get a dialog asking to open in WMP, Winamp or Take no action. I don’t see the Sansa in either of the programs but I’m running WMP 9, which may not be late enough. I do get the connect and charging screen on the clip. Maybe I’ll update WMP and see what happens, although that would only be as an exercise.

@dave61430 wrote:
I don’t see an icon in the task bar (MTP Mode). I get a dialog asking to open in WMP, Winamp or Take no action. I don’t see the Sansa in either of the programs but I’m running WMP 9, which may not be late enough. I do get the connect and charging screen on the clip. Maybe I’ll update WMP and see what happens, although that would only be as an exercise.

For MTP to work you need at least WMP10, unless you have already downloaded the MTP drivers from Microsoft elsewhere.

:diamonds::spades:

re: ankurchauhan’s post (#3) above:

NOW I VE JUST FOUND OUT A SOLUTION

 

when i plug it in usb … it shows message but doesnt show in My computer but sansa shows connected but not charging ( isee that many prople have same problem in forum so i posted my solution) then i clicked that harware icon which comes in taskbar just when u plug … then i click sansa and then UPDATE DRIVER … then it shows MTP device and come file transfer type icons and then my device back to normal as i see sansa icon comes back :smiley:

Not so beaten to death, this was the first really helpful post for my situation I found!

AutoUSB >> got Da-dunk sound, but nothing in My Computer.

Changed to  MSC mode > plugged in and Sansa was recognized, BUT Music folder showed empty. 

    >>As noted: files uploaded in MTP mode were not visible in MSC mode, so that explained that.

Also, in WMP the player showed “No Files” even though it was half full.

    >> By experimenting, in MSC mode, WMP ONLY shows files uploaded with sync. If you did a drag & drop with windows file manager, I’m guessing doesn’t update the album info data file, so these orphened files go unrecognized.

To recognize the player, I couldn’t recognize the files. Sooo I couldn’t copy (or delete) them to re-upload under MTP so everyone would work & play well together. GRRRRRR!

Your answer got me going in the right direction:

 MY SOLUTION:

 After a few plugins, I wasn’t getting an icon in the taskbar (tray you mean?) in MTP mode. But, I went to the Device Manager, found the yellow highlighted USB item (if you don’t see one, hit Scan for New Devices button on top bar right side), rightclick>Update Driver, looking on the Web, and the Sansa was once again recognized as an MTP Device. I was able to access the files already loaded. 

Message Edited by mankx on 09-28-2009 04:06 PM

Message Edited by mankx on 09-28-2009 04:09 PM

Message Edited by mankx on 09-28-2009 04:09 PM