I upgraded Sansa Clip firware & now i cannot see the files i previously had in it

hi guys, here’s my problem: i have a sansa clip v2, it worked quite good until yesterday, when i upgraded the firmware with sansa updater; the upgrade went smooth, but now my windows xp sp3 sees the player as it was a normal penstick/external hd, and i cannot see the files i previously had in it: i still can listen to them - the players works as usual - but, as i can’t see them, i cannot delete them! i tried the “show hidden and system files” in folder options, but it didn’t help. i think that after the upgrade the folder internal stucture has changed a little, now it is: audible, audiobooks, music, podcasts, record, WMPinfo.xml, MTABLE.SYS, RES_INFO.SYS, SYS_CONF.SYS, version.sdk. i try to put some new files in the “music” folder and it works perfectly, they appear in the player, so the problem is only with the old ones; as a matter of fact, i would not mind delete those files if it should be necessary, for i have them on my harddisk).

i hope somebody can help me, thanks a lot! (and please excuse my spelling & grammar mistakes, i’m italian! :slight_smile: )

It sounds like you originally put your music on the Clip in MTP mode, and the Clip is now in MSC mode.  You can switch between modes by going to Settings -> USB Mode in the Clip’s menu.

thank you, you’re very kind! as i am not so skilled in these computers-related matters, could you be even kinder and tell me precisely where should i look for these “settings” from where it’s possible to switche between msc and mtp, because i wasn’t able to find it thanx!!!

On the Clip, under Settings (press the Home button and then scroll down, using the bottom of the wheel), and then USB.

When firmware gets updated, the USB setting gets set back to (either Auto or MTP, I forget which).  Just try re-setting to MSC or MTP, and your songs should appear.  The underlying reason:  files transferred to the Clip while connected in USB MSC mode only appear to your computer when you are connected in MSC mode, and the same as to MTP.  And if the Clip USB setting is set to Auto, the Clip tries to connect in MTP mode but will fall back to MSC mode (and hence should be avoided, in my opinion, as it causes uncertainty–easist just to use MSC mode, which works for everything but DRM protected files). 

Hope this helps!

From the Clip’s main menu, select “Settings”, and then select “USB Mode”. 

The “USB Mode” setting should be there, unless you have an old version of the firmware installed.

thank you, miikerman! you explication is crystal clear, but i still can’t understand where do i find these “settings”… i know, i know, i’m quite dumb, but that’s it! if you could have the patience to guide me step-by-step through this, i’ll be very gratefull!!! SO:

what does it mean “On the Clip”, the clip folder? this is how it looks (sorry, italian language, but i think you could recognize the menus from their position), where are the “settings”?
![](C:\Documents and Settings\robi.kos\Desktop\Immagine1.bmp)
Otherwise, does it mean in windows main menu? i tried to look for it by myself, but… no results…

thanks fro replying!!!

oh no, i can’t even load an image!!! what a disaster :(… sorry!!! however, the idea was that it looks like every other windows folder with the “file” “edit” “visualize” “tools” menus above and the list of the internal folders below…

@robikos wrote:

thank you, miikerman! you explication is crystal clear, but i still can’t understand where do i find these “settings”… i know, i know, i’m quite dumb, but that’s it! if you could have the patience to guide me step-by-step through this, i’ll be very gratefull!!! SO:

what does it mean “On the Clip”, the clip folder? this is how it looks (sorry, italian language, but i think you could recognize the menus from their position), where are the “settings”?
![](file:///C:/Documents%20and%20Settings/robi.kos/Desktop/Immagine1.bmp)
Otherwise, does it mean in windows main menu? i tried to look for it by myself, but… no results…

thanks fro replying!!!

 

“On the Clip” means the physical Clip.  The player, to which you connect headphones.

1.  Pick up your Sansa Clip player–the physical player you bought.

2.  Turn it on.

3.  Press the little “home” button, the small button on the front of the Clip located at the upper right of the big wheel–it’s the small button with the little house printed above it.

4.  Press the bottom of the big wheel (at the 6 o’clock position) until the display shows Settings.

5.  Press the right side of the big wheel (at the 3 o’clock position) once, to enter the Settings options.

6.  Press the bottom of the big wheel (at the 6 o’clock position) until the display shows USB mode.

7.  Press the right side of the big wheel (at the 3 o’clock position) once, to enter the USB mode options.

8.  Press the top or bottom of the big wheel (at the 12 and 6 o’clock positions) to scroll to the MSC setting, and then select it by pressing the right side of the big wheel (at the 3 o’clock position). 

9.  You now have set your Clip player to MSC USB mode.  Press the little home button a couple of times to return to regular play mode.

And that’s it.  Now when you connect your Clip player to your computer, your files should show up on your computer.  If they do not, repeat the above but set the USB mode to the MTP setting.

I hope this helps–

1.  Pick up your Sansa Clip player–the physical player you bought.

2.  Turn it on.

3.  Press the little “home” button, the small button on the front of the Clip located at the upper right of the big wheel–it’s the small button with the little house printed above it.

4.  Press the bottom of the big wheel (at the 6 o’clock position) until the display shows Settings.

5.  Press the right side of the big wheel (at the 3 o’clock position) once, to enter the Settings options.

6.  Press the bottom of the big wheel (at the 6 o’clock position) until the display shows USB mode.

7.  Press the right side of the big wheel (at the 3 o’clock position) once, to enter the USB mode options.

8.  Press the top or bottom of the big wheel (at the 12 and 6 o’clock positions) to scroll to the USB mode setting that currently is not checked (I think it will be MTP; ignore the “Auto” setting, for the reasons I noted above), and then select it by pressing the right side of the big wheel (at the 3 o’clock position). 

9.  You now have set your Clip player to MTP USB mode.  Press the little home button a couple of times to return to regular play mode.

And that’s it.  Now when you connect your Clip player to your computer, your files should show up on your computer.  If they do not, repeat the above but set the USB mode to the MSC setting.

I hope this helps–

P.S.  As I said earlier, of the USB modes, the MSC mode (as compared to the MTP mode) is more universal and will work on more computers.  If you use your Clip player on other computers, you may want to set your Clip player to MSC mode, to make sure it will connect to other computers.  If that is the case and if your Clip player has been set to MTP mode up until now, before you change the USB mode setting to MSC mode, to be able to see all of your Clip player’s files on your computer, first copy your Clip player’s files back to your computer, delete them off of your Clip player, set the Clip player’s USB mode to MSC (see the above), and then copy the files back to your Clip player.  This will assure that you can see all of your Clip player’s files, when connected to your computer.

IT WORKS!!! yes yes yes!!! MIIKERMAN, you really are my sansa guru!!! and it was THAT easy, i just didn’t catch it, dumb me!!!

THANK YOU!!!

Great to hear!  And it’s such a shame that SanDisk hasn’t kept its instruction manual up-to-date, for matters such as this.

I believe I have a very similar problem, but the solution you mention is not working.

My Sansa Clip 2G worked just fine.

I got a new computer with Vista.

I upgraded my firmware.

I’ve switched to MSC mode.

I reinstaleld Rhapsody.

In Rhapsody, the amount of space bar at the bottom of the screen shows that I have used half of my Sansa drive. I agree with this.

But, I cannot see any of my songs. The songs play fine with headphones.

When I go to My Computer, Click on Sandisk, I get the sets of folders everyone mentions. When I click on the Music folder, it’s empty.

How can I see my songs? Where did they go?

Thanks kindly,

Chris

From the computer, files transferred in MTP mode will not be visible when in MSC mode, and vice versa.  The Sansa sees all files, regardless of mode used for transfer.

This is why your music folder looks “empty” when viewing the device using MSC mode.

If you switch to MTP mode, you will be able to access your files.

µsansa

Also:  Rhapsody applies digital rights management (DRM) to its files.  For DRM, your Clip needs to be set to MTP USB mode (this is the only real advantage I can see to MTP mode). 

Milkerman

I have gone through all the steps you have so clearly outlined, but I still cannot see the files on my Clip that were originally put on when in the MTP mode (or maybe auto detect). Now that I have my clip in MSC, files that I have put on my clip while in MSC are visble on my computer, but files put on when my clip was in MTP are not shown.

When I switch my clip back to MTP, my computer does not recognize my clip at all.

Do you have any suggestions? Is there any way to delete all the files that I have on my clip?

Many thanks…

Larry

This is why I dislike MTP mode–it just doesn’t work, sometimes, in contrast to MSC.

At this point, especially if you have you copies of your music elsewhere, you could format your Clip (under the Clip’s Settings menu, scroll down to Format, right click to enter that menu, and then highlight and right click Yes).  That will erase all your content files off the Clip, but you then could transfer your music, podcasts and audiobooks back to the Clip from your computer while you are connected to your computer in MSC mode, and it all will be visible on your computer when you are connected in MSC mode (which is working for you).

Alternatively, you could connect your Clip to your computer in MSC mode, see what files show up on your computer, write them down, and then disconnect your Clip and delete the other songs from your Clip one-by-one (while the song is playing, click the bottom of the Clip’s wheel until you see a delete option, and then right click or center click on that to delete), and then add them back to your Clip while connected to your computer in MSC mode.  Although this is a bit more cumbersome …

For ease, and assuming that you have copies of the files elsewhere, I would do the first option.  It really will be pretty easy to do.

Milkerman…

Thanks so much for your clear directions. This worked perfectly!

Larry

Great to hear–enjoy it!

Yeah! Thanks!!! I have found my music! Thank you!!!