Sansa Clip 8GB - Firmware Version 2.01.32 - All Of My Files Have Disappeared

So, today I updated the firmware on my Sansa Clip from 2.01.16 to 2.01.32 and now, as a result, when I connect my player to the PC none of my files stored on my player are visible. I have tried using the options to show hidden files and system files on my PC but this does not work. All the files are still visible and playable on my player, and my PC shows that there is 5.58GB of space being used on my player but when I search through the player’s folders using my PC they are all empty… not so much as a single byte in sight… What’s going on? Where are my files being stored now? (And most importantly) How can I access them via my PC?

I read on a website that deleting the “MTABLE.SYS” file would fix this issue but I have tried this 4 times now and the problem still persists.

Many thanks to anyone who can help.

Probably not an error but a MSC / MTP issue. Go into the clip setup and select MTP. If still no files then select MSC.

If still no files the follow the instructions in the FAQ on this site.

How do I go into the clip set up and how do I select MTP or MSC?

@ pernilleib

Nevermind that last question. I figured it out by looking in the FAQ.

I solved the problem by doing as you said, I switched to MTP mode and now all my music is visible again :smileyvery-happy: