Can't reformat the MicroSD I've been using in the Sansa Connect

I’ve been using an 8 GB Sandisk MicroSD card in my Sansa Connect to store Music and Videos, I uploaded most of the content via the Connect connected to the USB port on my PC and it’s been working fine that way for months. Now I removed the MicroSD and put it into my cellphone, but the cellphone didn’t recognize the card at all. So I tried the MicroSD via my PC’s cardreader and I got the error that the card needs to be reformatted, but when I try to do that in Windows it says “Format can not be completed”. So my first thought was that the MicroSD card was broken, yet when I put it back into my Sansa, it still worked fine and I can still use the music and videos on it, and even upload new stuff via the Connect.

So could someone tell me what the Connect did to the card that it won’t work in other devices and readers and how to undo it?

The Connect loads music onto the card via MTP.  Not sure if this is causing what you’re seeing.  You could try the H2testw utility (Google it) to test your card.

The H2testW App won’t work until windows recognizes the drive. It just gives the same error as windows does now.

I tried another card reader on another PC and it’s giving the same problem. The card shows up as a removable drive in windows but it won’t read or format. The windows Disk Manager can’t find it either. If the card wasn’t working in the Sansa I’d think it was broken, but it still works fine in there.