My sansa connect won't read micro card. Please Help.

Hi,

  I purchased a Sandisk Sansa Connect. I also purchased the sansa sd micro card. My problem is that I’ve tried every trick in the book to get the sansa connect to recognize the 4gb micro card but it still won’t. I’ve tried erasing everything and copying the material back into it but nothing works. I took it to the dealer where I purchased it and even the “tech” guy told me to come to this community. - please give me some ideas to try. John.

Message Edited by Jf3030 on 03-08-2009 01:30 PM

@jf3030 wrote:

Hi,

  I purchased a Sandisk Sansa Connect. I also purchased the sansa sd micro card. My problem is that I’ve tried every trick in the book to get the sansa connect to recognize the 4gb micro card but it still won’t. I’ve tried erasing everything and copying the material back into it but nothing works. I took it to the dealer where I purchased it and even the “tech” guy told me to come to this community. My direct email is <–Snip–>

please give me some ideas to try. John.

John,I cant really helpyou as I am becoming re acquainted with my connect. What I can tell you is to edit your post (Go up to Options>Edit Post) and take your e-mail out. This is an open site and Spamers can and will get your e-mail and load you down.

@jf3030 wrote:
My sansa connect won’t recognize the micro card. I plugged it in … shut it off … turned it on and still will not recognize the 4 gb micro card. Can anyone help? John
Message Edited by Jf3030 on 03-09-2009 08:08 AM

I don’t have a connect myself, but I can suggest that you post a message here http://forums.sandisk.com/sansa/board?board.id=connect 

and you may have better luck getting an answer  :smiley:

I know you’ve tried everything :wink: but have you tried reformatting the card?  If so, with what file system did you format it?

It’s possible there is a hardware problem with the card slot.  Did the tech guy at the dealer try putting a different card in the slot?  That would have been the best way to diagnose the problem.

Try updating the firmware. The original version only supported a 2GB card.

The latest firmware supports (at least?) 16GB.  :slight_smile: