can't authorize for rhapsody on sansa clip

Just bought a 2g pink sansa clip a week ago and no matter how hard I try it will not allow me to synch so I can use rhapsody to go. 

First had problem getting pc to see device…putting device in hold mode and holding center button when plugging in fixed that problem.

Now best buy music store, windows media player 11, and my computer see the device

COOL! 

I can transfer normal content to it but it won’t even let me authorize it for subscription content though.

What have I done to try and fix it?

updated firmware to 1.01.29A

ran device reformat 

Running windows vista sp1(32 bit)

running windows media player 11

running latest version of best buy music store(reinstalled multiple times)

downloaded the 929399 fix (tried again to be sure and says it cannot be run again on my pc)

unauthorized and reauthorized my pc within the software

tried all this in auto mode, msc, and mtp…no go on all 3 attempts.

Literally did everything I could find on these forums and all other forums referring to authorization issues on the sansa clip.  Still having problems as it won’t let me authorize the device.  Tried it in best buy music store, also downloaded the to-go file and tried transferring in windows media player 11 with no luck.

Checked the account in best buy music store and it is set up for a to go account until sep 6.

Am I missing something?  Is it a bad player, or is it my pc?

Try to reinstall Rhapsody.

Make sure you have a Rhapsody to-go account or 30-day trial account.

Reformat your Clip.

Also make sure u downloaded the song from Rhapsody by right-clicking the song(s) and click the Download Track(s) option.

Then click on the Tools TAB on the top left and click the Peferences option and go to devices option  and click add a new device.

Then it will give u a drop down option that says browser by >look for Sandisk then you will see Sandisk Sansa Clip and other Sandisk mp3 players.

Click on the Sansa Clip Blue letters and go to the right it will give you an option to install player. Click it. If all goes well you will see it in Rhapsody.

Then authorize the device then drag and drop the songs/albums.

Good Luck:smiley:

Message Edited by SYLUXSPIRE on 08-13-2008 12:55 AM

think we are getting somewhere.

The tools, add device and install player piece is where I am at right now.  Says rhapsody needs to download an update but then nothing happens.  I think this is the missing piece to fixing this.  Will keep you updated…if I can find the update :slight_smile:

I think I know why it won’t let me authorize it.  The only way my computer wil recognize the clip is if I due the hold/center button trick.  Was reading another forum and apprently that forces the device to load in msc mode…which as far as I understand it will not allow the device to use subscription content…hence my inability to get the device authorized.

Thanks for the help so far.

So I guess my issue now is how do I get my pc to recognize the device in mtp mode.

I already downloaded the mtp patch for media player, use windows media player 11, and have upgraded the device firmware to the newest drivers.  But my pc refuses to recognize the device in mtp mode…anyone have any suggestions?

Message Edited by aero on 08-13-2008 07:07 PM

GOT IT!!!

This is for vista 32 bit by the way 

First redownloaded the mtp driver from windows and clicked repair 

Then I went to device managers and went through to manually update the mtp driver.

to do this you right click on the mp3 player device, and click “update driver”

from here you will say browse…don’t search

next say let me pick and update the mtp driver

let it do its stuff.

Still didn’t work for me though…well crap…kept getting a code 10 error

searched for code 10 on these forums and saw someone say something about their code 10 issue being fixed by uninstalling the ps3 controller to pc patch

…I HAVE THAT PS3 PATCH!!!..

uninstalled it and IMMEDIATELY the mtp device started working

Hope that helps everyone else

Im having the same problem on this machine.  I did the steps listed to try to add the device but Im already running the latest version of Rhapsody and it still says that I need to update before it can install my device.  I can only get it to find the device by doing the trick like aero mentioned but doing so disasbles my ability to transfer music.

Im running XP so not sure if his fix for vista will do the same for me.  But I can figure out why the clip works on my computer but not my girlfriends.   

Aero-

Bravo!  I read down the thread, waiting to see if there’s be a mention of the need to use MTP Mode for all WMDRM issues, meaning all protected media like Rhapsody, Napster, Overdrive, et cetera.

When you’re in the Rhapsody 4 client, there’s a big hint as to the device status.  If your device lists in the Sources pane as E:SANSA CLIP, all in capital letters, with a drive letter assigned, it’s in MSC mode, and cannot handle Digital Media Rights.  Note that if you right-click on the Clip in this pane, the Authorize option is not available.

If you are using your Clip in MSC mode with Rhapsody, only purchased individual tracks will transfer (No DRM!) to the device.

When your machine is in MTP mode, the R4 client will list the device as Sansa Clip 2GB, for example.

I had a peek at the Microsoft download site for the fix you mentioned, and haven’t quit laughing at the suggestion:

If you experience some other problem with Windows Update, you might want to ask someone for help or contact support. For information about how to do this, visit the following Microsoft Web site:

For those who know Eddy Izzard, I must insert the reply, “Well done!  Well done indeed!”  How about putting it in black and white, Microsoft?  Better yet, how about designing MTP and Vista to work properly in the first place?

The PS3 driver issue has become a popular sticking point as of late.  If you are having trouble getting the MTP protocol to work, so that you can enjoy services such as Rhapsody, keep it in mind, as yet another wee bump in the road to musical happiness with your Sansa.

Bob  :smileyvery-happy:

“If your device lists in the Sources pane as E:SANSA CLIP, all in capital letters, with a drive letter assigned, it’s in MSC mode, and cannot handle Digital Media Rights.  Note that if you right-click on the Clip in this pane, the Authorize option is not available.”

I recently upgraded from Windows XP to Vista and am now having the above issue.  Unfortunately I didn’t understand what the gentleman above did to fix it.  If someone could explain it to me in *cough* laymen’s terms, I’d greatly be appreciative.  

Thank you :slight_smile:

Nevermind…just figured it out lol.

I have a pink sansa also. And i cant authorize it either. It worked great on my old pc but I got a new pc and it wont authorize. I checked my authorized pc and I have 2.  I only have one other devise. i did all the other steps e.g

I can transfer normal content to it but it won’t even let me authorize it for subscription content though.

What have I done to try and fix it?

updated firmware to 1.01.29A

ran device reformat 

Running windows vista sp1(32 bit)

running windows media player 11

running latest version of best buy music store(reinstalled multiple times)

downloaded the 929399 fix (tried again to be sure and says it cannot be run again on my pc)

unauthorized and reauthorized my pc within the software

tried all this in auto mode, msc, and mtp…no go on all 3 attempts.

Still no change. I called Rhapsody and Sansa and still dont have an answer for me. Can anyone help. Oh and It works great on my home pc .