Sansa Clip and Rhapsody To Go.

I have Rhapsody To Go, and when I drag my songs over to the players icon it says I need to buy the tracks because my device isn’t capable with Rhapsody To Go. I was told to authorize my device by right clicking on my players icon , but when I right click on it, it doesn’t give me that option. I know that the Sansa Clip is capable. What Should I do??

Check out this How To Video on how to Authorize and let us know if you still have issues.  Click on the Video link.

Authorize an MP3 player in Rhapsody (Video)

Go Sansa!

Make sure your USB mode is NOT set to MSC.

Update to WMP11 if you have not done so. 

Also be sure to have the latest Rhapsody Client by clicking on Help/Check for Updates.

Go Sansa!

Thanks, I’ve tried this but when I right-click on the device icon it only gives me three options to choose from and authorize isn’t on the list…

try to deauthorise then reauthorize your computer under “My Account”

 How many devices do you have authorized?  Three is the limit.

View them under “Authorizations” 

IS the clip connecting in MTP mode?  please confirm that the USB Mode is set to “MTP”

You can see the connection mode of your sansa in the sources pane of the Rhapsody 4 client too:

If the sansa is listed as SANSA CLIP (E: ), listed all in caps, with a drive letter assigned, it’s in the wrong mode for Rhapsody.  DRM transfers are not possible.  It should be listed as Sansa Clip 2GB , in caps and lower case, when in the proper (MTP) mode.

I think this is the case, as Rhapsody is saying “purchase”.  Note, I have several Rhapsody accounts.  It’s possible the device might have the wrong e-mail account listed, which can also toggle the “purchase” prompt.  Check this via settings > account on the sansa.

Be sure to have Windows Media Player 11 (I believe 10 will also work), as this application contains the MTP drivers required for transfer.

If your sansa is connecting in the wrong mode, simply disconnect, and navigate on the device to Settings > USB Mode > Auto Detect or MTP.  It will try MTP mode first when in Auto.  If you do NOT have the USB mode selection option, your device has the early 1.01.11 firmware.  Confirm this by going to Settings > Info.  The firmware version is listed there.

If you are still unsuccessful connecting in MTP mode, let us know.  The most important key for your Rhapsody situation is whether the ident is in CAPS or a Mixture, as this will show how Rhapsody is communicating with your sansa.

Bob  :smileyvery-happy:

someone help before I jump!  I got a sansa clip 2GB and a sansa clip 1GP for christmas gifts.  I can’t get the 2GB to add.  I get a message that says Rhapsody need to “do an update to support my portable device”.  I only found this by my own looking around for a place to add device.  I contacted Rhapsody chat support - they couldn’t even tell me to go to the Add Device option (found in Tools/preferences/devices).  My device is connected to my PC.  I have authorized my PC.  what do I do?