need MTP mode to work w/Rhapsody on the Go, already downloaded MTP files...

I’ve been subscribed to Rhapsody for 2+ years and bought the clip to replace an older Sansa MP3 player that worked with Rhapsody.  I can get it to work in MSC mode and Rhapsody sees it and will transfer files that I own to it.  However, to take advantage of the Rhapsody “On the Go” tracks, I need to be able to use MTP mode to allow Rhapsody to transfer songs with DRM info.   Anyone been able to do this succesfully?  I’m wondering if it’s an issue with the fact that the first time I hooked it up to the computer I didn’t have the MTP add-in on the computer yet, so it forever wants to recognize this using MSC mode only?  When hooked up to Rhapsody in MSC mode, it shows on the “My Computer” page and it shows in the Rhapsody screen, but when you right click on it the menu of options it doesn’t show the option to “authorize” or “de-authorize” the player. thanks.

Go to Settings/USB Mode/MTP.

It should show up properly after changing the USB setting.

Also, make sure you have WMP 10 or 11.  Windows MTP drivers are installed by WMP.