Can't add new songs to m250

I cannot add new songs to my m250.  When I first bought the device, I copied 285 songs and filled it immediately.  To be honest, I don’t remember how I copied the music that first time. 

Its been about two months, and I wanted to refresh it by deleting what’s on it and add new music.  The problem is my PC doesn’t seem to recognize the device.  I have watched the instructional videos, and they don’t seem to help.  The problem is my device is not listed in My Computer.  When I connect the device it shows “USB Connected MTP” on the screen.  And, my computer pops up a little window saying new hardware found.  It then prompts me to restart the PC so the new device can be used.  But, this doesn’t help.  I still don’t see the device listed after restarting.  Obviously, I can’t do any file manipulation if I can’t get my PC to see the MP3 player.

The device is an M250, and it has v4.1. 08A firmware.  I’m running Windows XP, with Windows Media Player v 11.0.

Any help would be greatly appreciated 

I had a couple of similar problems and here is how I solved them, not making any claims to fixing yours:

  1. Open Windows Media Player. Click on Tools  then Options. Select Privacy tab. Click on the Clear History and Clear Cache buttons.  This removes any history of your player from WMP and somehow from Windows Explorer.  My Windows Explorer was showing two m250’s even when it wasn’t connected.  This fixed it.

  2. On the m250, press the menu button, select Settings , Reset All.   Press the forward button to highlight the check mark at the lower right, then press the Center button.  This resets the player to it’s like new condition.

If neither of the above fix it and it is under warranty, contact tech support about a replacement.  If it is out of warranty, follow the link below to a fix for freezing, which may let you connect to the PC and format the device.

I know this works.  I used it on a unit I had tried changing the version level on and failed.


Thank you for this. I had exactly the same problem and your very clear instructions fixed it.

Really appreciate it, thanks!

I had never heard of MTP and MSC before until today when ironically the same situation came up on a new Sansa Fuze. I found the solution to that in the manual, but couldn’t find a manual for the m250 on the Sansa website.