C150 is not working/Please help

Hi,  I just bought the Sansa c150 last night and now I am reading on this site that the thing is a legacy product! 

My issue is that i tried it out last night and it worked great.  I bought it to go listen to music while mountain biking.  I had it mounted in a neoprene carrier and it hung from my neck on a lanyard.  Half way through my ride, the Sansa started acting up and wound not respond to my commands.  I had to pull the battery to reset the unit.  After fumbling with it for a bit, i managed to get it to work again.  I got a bit further, and it then just completely stoped.  The unit said low battery and shut off.  Now I am home, I tried it again, and it turned on showing a full battery, but it will not play.  I tried hooking it up to my PC, and it now won’t even turn on.  What is the deal with this product?   I though SanDisk made quality product?  I have other memory items of theirs and they work great.  I was sweating, and it was very humid, but it was not like the player was saturated, and it was in a neoprene case.  Can someone please offer some advice?  Do i need to return it, but only to potentially get another bad player?  What should i do?

Thank you,


Sounds like it might need to get replaced like you think.

Hello there, I am having problems with my Sansa C150 too. This is my second one, since the first one I already returned to the store within the first month of purchase for the same problems. The store gave me a second one which I have kept for a little over a month, so now I’m stuck with it.

My device was functioning well, then suddenly, boom, all songs disappeared! The device takes so long at the boot screen, and when it gets into the Menus, it says “No song” ! I can still use the menus to browse around, but when I press Play, the device hangs indefinitely. Neither changing new batteries nor formatting the device using MSC or MTP mode would help. When I connect the device to my computer in MSC mode, I can see 3 folders AUDIBLE, RECORD, CONFIG, and a VERSION.SDK file in the root directory, but no MUSIC folder! I try to format it, and always get the error “the formatting can’t complete” or something like that. When rebooting the device, all the folders are still there without the Music folder (and yes, I view the files with the option “Show Hidden Files and Folders” selected). I also got the error “Not enough space for DB, please delete at least 4MB” upon rebooting the device. But ironically, the device doesn’t let me delete anything! When viewing its Properties, the space occupied by my mp3 songs is still counted, it’s just that neither my PC nor the device can see them. If I re-create a new Music Folder in the device’s root directory, then copy songs to it, upon rebooting, the Music Folder and the songs continue disappearing. I suspect a total system files corrupt, but there is no way for me to reinstall the system files or upgrade the firmware. Please help!

I would contact Sandsk and see what they sya. 

Thanks. I already contacted them before posting here. All they could tell me was try formatting the device in MSC mode, which I already did before contacting them and told them so.

I’m having a very similar problem with my Sansa C150. I’ve had it around a year now and I plugged it into my laptop the other night to add to the music that was on it, and when it was finished syncing, I unplugged it, and all of the songs were deleted. when it’s plugged in, it says that there is a lot of space being taken up by the songs that are on it, but when it is not plugged in to the computer, it says there is no song on it. I format it, and re-install all of the songs on it, and the result is the same. Could any one please help me?