Black screen and format question

Hi,

A couple of weeks ago I bought my Clip Zip. I could connect it to my PC and put music on it.

I took it with me during a run, and everything worked fine. After the run I charged it with an external charger (5V, 1A max) for a couple of hours. During plugging in _and_ plugging out, the screen illuminated. So far so good.

A couple of days later, I want to use my device again, but it won’t turn on / no music / black screen.

When I connect it to my computer, the device driver fails to install nor recognizes the mp3 player. I see an additional hard drive, but Windows asks me to format it.

It seems to me like corrupted flash, although the player was only charging the last time the screen lit up.
 I searched this forum for an answer and I tried the multiple minutes-taking resets and charge sessions (via my PC). Nothing works so far.

What would happen if I allowed Windows to format that hard drive? Would it maybe solve the problem or make it just worse?

Hopefully you have some good advice. Worst case I can send it back to my supplier, since I bought it less than a month ago.

Thanks in advance!

Have you tried simply resetting it? Press and hold the power button down for 20-30 secs. Release, then press the power button again momentarily to power it on. With any luck, it should start up normally.

Yes, that is the first thing I tried, and I have tried it many times later on. Resetting it does ‘something’; when it is connected to a computer the additional hard drive dissapears after about 10 seconds when pushing the power button. After a restart, that hard drive is shown again (with the question to format it), but notthing appears on the display of the mp3 player.

You need to be resetting the player when it is not connected to the computer.

I did that as well, but then there is no sign of life.

And, did you hold the button down for 30 seconds or more? Some users also have reported success by pressing the on button along or in succession with another button, such as the home button or center button, or the left button (I know that this latter comment is vague, but the success method really has varied and it all may just be serendipity).

I’m going to pick up this thread since I seem to be having the same problem as the original poster.

My screen is entirely blank and has been charging for most of the day (it went blank after I briefly turned it off at about mid-power).

I have tried resetting it with every button combination I can think of (holding for 30sec., 60sec. etc.).

When I connect it to my computer (Windows 7), it appears as a removable disk (incidently, holding the power for 15sec. will unmount the player, then pressing it again will remount it).

When I attempt to click on the ‘removable disk’ icon, it tells me that it needs to be formatted.  I’ve tried formatting it every way possible, and every approach has failed.  I’ve also deleted the clip zip from my devices folder.

The only other bit of advice I’ve found is to let it charge and rest for a few days.  Any other ideas?

Cheers.

One more note.  When I click on the drive, it gives the capacity as 30.6MB.  From what I’ve seen, this isn’t a good sign.