Battery shows low (and turns off) after being charged & Updater doesn't recognize device.

I bought my Clip + a year or so ago and things have been fine until now.

Had my (charged) device in my gym bag over the winter and have since used it several times (about 2-3hours). The battery was then exhausted and needed a re-charge. I charged it overnite (the ‘charging’ display came on to indicate it was being charged…supposedly and it even said ‘connected’). Needless to say it was NOT charged and in fact had a line across the battery symbol.

I then tried to hook up with the Sansa Updater while the device was plugged in. It said it ‘didn’t recognize an updatable Sansa device’ and kept searching continuously. I unplugged and plugged back in the device to no avail, even though I would hear the sound on my computer that indicates a device is plugged in.

I then clicked Sansa Support and chose the solution that ‘Windows didn’t recognize my device’ and proceeded to remove

VID_0781 flies from my registry (as instructed). Still nothing.

I initially got the Clip+ because I wanted to be able to change out the battery should it go dead and become UN-chargeable as in my previous mp3 player, but I don’t see on the device WHERE/HOW I would be able to do so (should this be the issue).

In fact I don’t even see where Sansa offers replacement batteries.

So as it stands,

1. Battery doesn’t charge.

2. Can’t load/delete/view music

3. Updater doesn’t recognize device.

Thanks for the assistance.


Have you tried different USB ports or a different computer or AC-USB charger? You might leave it alone to charge for a long period of time; sometimes it trickle-charges. But in the future, you probably don’t want to store it in a depleated state

Where did you ever get the idea that the Clip+ had a removeable or replaceable battery? It doesn’t. The last model that did was the e200 series, discontinued about 3 years or so now.

Dont try to use the Updater until you get the battery charging business settled. In fact, there’s no reason to use it at all. It is a resource hog on your system and it actually takes less time to “manually” update the firmware than it does to install the Updater and wait for it to do it. Besides, the Clip+ too, is at the end of it’s life cycle so there won’t be any further firmware updates for it.