sansa clip plus charging and updating problem

I have a sansa clip +.  The battery died so I plugged it into my computer and it says on the player that it is “connected” but my computer doesn’t show that anything is connected.  After a couple of hours I checked it (computer on the whole time) and there is no charge.

I went on the website and try to download an update but again the sandisk updater says that the player is not plugged in. 

I tried pressing the down power button for 30 seconds and the player did turn off.  I turned it back on and again it says that it is connected but the computer does not.

I tried pressing the power button again for 30 seconds, turned it off, unplugged it from the computer and turned it back on.  It said that it is updating the files and then said the battery is low and before it shut off I plugged it back into the computer and again it says it is “connected”, but my computer and the sandisk updater is not recognizing it.

I did check to see that my windows media player is updated.  It is version 12.

HELP.  Why won’t it charge and why won’t my computer recognize it???