"Battery Low" problem

Hello - hope somebody can help me. I have been in contact with support with this problem but I thought it might be an idea to air it here as well.

In late March this year I purchased (through Amazon) a Sansa Clip +, which, until about a week ago had worked perfectly.

Then came a problem. I had been listening for about an hour when it switched itself off. After several unsuccessful attempts to switch it back on, it eventually obliged, but came up with the message “Battery Low”. I found this rather surprising, as I had recharged the battery only two days earlier. Perhaps I should mention here that I use an AC charger.  Given that my level of usage has dictated a need to recharge about every three weeks, you can imagine why it was that I was surprised. At that stage however, I thought that I had done something stupid and simply tried to charge it again, leaving it plugged in overnight.

Sad to say, this has achieved nothing. As before, it took several attempts to switch on, and when it did finally respond it generated the same “Battery Low” message.

I then tried plugging into my laptop (OS is Vista), just to see what would happen. The short answer to this was “nothing”. When I clicked on My Computer there was no sign of the device. I then tried plugging in to my desktop (OS is XP) with the same result.

I have tried following the suggestions on the support website, all without any luck. Attempts to update the firmware (I’m currently on v01.01.05f) came to nothing - error message to the effect that no firmware was available?

Any suggestions would be appreciated.

Thanks in advance

Press & hold the power button for 15-20 sec. Connect to power when it starts up, but before the «Battery low» message appears. Make sure your power source is actually supplying power.

If this does not help, contact the support for exchange — you are still under warranty.

P.S. Do not attempt to update the firmware while the battery is low and charging isn’t working. It needs to be updated, but not until there is enough power.

Message Edited by notgod on 08-12-2010 02:13 PM

Try charging the player with an AC usb charger. Many people have one of these that came with a cell phone or digital camera. After that, if the player turns on, go to settings and make sure the USB mode is set to msc, then you can try to connect it to the pc.

Thank you both for your responses. I have come to the conclusion that I have a knackered battery. As I have tried charging from 3 different sources (AC charger, laptop USB and desktop USB) without any luck…well I cant believe all 3 are no good, especially as I use the AC charger for my mobile phone and it works fine for that.

Looks like I might be looking for a warranty replacement.

Thanks again