Battery will not charge fully

In May 2008, I got a 2GB Sansa Clip for my birthday (as a gift, so no reciept).  It worked great until about a week ago when I let the battery run all the way down to the “low battery” state by accident.

Anyway, I’ve tried to charge it up using the USB cable, but it goes from no charge to “full” in about 30 seconds.  Then when I disconnect, it says “refreshing database”, then “low battery”, and it shuts off.

By repeatedly connecting and disconnecting it every minute or so over an hour, I was able to get it to hold 1/4" charge (enough that it does not immediately shut down after being disconnected), and I found I can get it to play.  But the “low battery” comes back in about 1-2 minutes, and it shuts down again.  I downloaded the firmware updater program, but it doesn’t seem to do anything when I run it.  How can I update the firmware?

I love this little mp3 player, but this problem is MOST annoying.  What can I do?

Also, what voltage and type (Li-ion, NiMH, or NiCd) is the internal battery?  If the unit is no longer under warrenty, I could pop it apart and try to replace the battery, or even install an exterior power connection for an external battery.



For the latest firmware and instructions on how to apply it, see the sticky thread at the top of the forum:

Your battery likely is ok–there seems to be a problem with the operating system.  Hopefully, reapplying the firmware will fix that.  You also could try a system re-set:  put the on switch in the uppermost position for 10-15 seconds.

It likely would be hard to replace the battery, as the Clip isn’t meant to be opened and you could crack the case in trying.  Hopefully, the above will work.

If not, I would telephone Customer Service and ask for a warranty replacement.