Clip says it's connected but wont charge and can't be seen in Windows Explorer (or My Computer)

What am I doing wrong?

When I plug it into USB slot, Screen lights up and says “Connected” but battery charge symbol is inactive and when I unplug it, “Battery low” message appears. The “Connected” screen seems to be draining the battery.

Also, I cannot see the Sansa Clip drive in explorer, Media Player or any other utility on my Windows XP (with SP2) system.

Just bought the thing and was able to play the factory installed songs and listen to the radio before; just can’t do anything else with it.

After reading more through this forum I have:

  • downloaded the firmware updater and the ‘20’ firmware update separately.

Problem is:

  • if the PC can’t see the Clip, how can I do a firmware update?

  • if the battery is low (& it is) I can’t go into system settings and see what firmware version I have.

I can’t seem to do anything with my clip right now.

Plugging it into the USB slot drains the battery (screen is on with connected message).

Unplugging it from the PC’s USB slot shuts it off and when I turn it on and try to access main menu (or anything else), I just get the “Battery low” message.

The CLIP doesn’t even make a useful paper-weight it’s so small and light :slight_smile:

Have you tried a different USB port and different USB cable?

Yes.

All USB slots are good (I’ve plugged other devices in and they’re good).

I always get the rotating “Connected” and “SanDisk” screen, but the Battery charge graphic shows charging activity for less than a minute then stops (empty battery graphic).

Does that mean it has stopped charging?

How long does it take to charge fully?

How would I know that battery is fully charged?

@pnd97 wrote:
Does that mean it has stopped charging?

yes, that means it’s stopped charging!

you say all your usb slots are good, but have you tried changing the cable as Miikerman suggested?

i had exactly the same problem and it turned out there was something wrong with the usb cable that came with the clip.

as soon as i used the one from my digital camera, everything was fine.

try that and see what happens.

also make sure you have windows media player 10 or 11 installed.

Also try it on a different PC, if you can.

I know you said you tried all ports, but I just thought I should throw this in; the Clip needs to be connected to a high-power USB port.

I got it figured thanks.

The cable may still be suspect but here’s what I did:

  • Plugged it into another PC’s USB port and it charged.

  • Set system settings / USB / to MSC (instead of Auto detect)

  • Plugged it back into my laptop and

All was well.

Lost previous uploads, but at least I can access the Clip as an external drive now.

I can live without RMA protection and Rhapsody access.

Thanks for being there.

Now I will do the firmware update from 18A to 20.

Huh, interesting … I would think that charging wouldn’t be affected by whether your Clip is in MTP or MSC mode, as I didn’t think that the MTP protocol extended down as low as managing power, but really I have no idea.  Someone?

I think it’s more likely that MSC mode support is something that comes with WMP 10 & higher (not with the WinXP OS).

I do not have WMP installed on this work PC.

There might still be a cable issue (?) but so far I’m good to go.

Good to hear.

MSC mode doesn’t need WMP, as far as I am aware.

@pnd97 wrote:

I think it’s more likely that MSC mode support is something that comes with WMP 10 & higher (not with the WinXP OS).

Do you mean MTP mode?  Yes, you would need WMP10+ for that.

 

But it still seems to me that even if the player is set to MTP or Auto-detect, the lack of MTP shouldn’t prevent charging (though it would affect syncing).  But someone might correct me on that.

I had the same trouble = I didn’t have the plug pushed in all the way on the player = it was lit up & slowly charging = but nothing came up on my computer = what an idiot = my son pushed the charge cable in on the player as far as possible & it worked no problem = EASY fix after 2 hrs. of wasted trying

Message Edited by 2brokenheart259 on 03-19-2008 02:16 AM

IT FINALLY WORKS !!! Sandisk Tech support had me do the following: -          Turn it OFF-          Put it in the HOLD position-          HOLD the center button IN while plugging into USB port, continue to hold for 5 to 7 sec even after plugged in.At this point MY COMPUTER recognized it. And it worked. He also had me to: - go to WWW.MICROSOFT.COM- In the upper right hand search bar, type in MTP PORTING KITI did this and downloaded the first one. Now my Sansa Clip work perfect. I wish I would have talked to him last week before I returned the last one, for the same reasons. If this does not help call the 1-800 # , opt #4, and ask for GUY (yes that is really his name) out of 5 or so calls to Tech Support he is the only one who knew what he was doing, and how to actually HELP.GOOD LUCK