Bad e260 V1 Experiment

Just for the heck of it I bought a broken e260 V1 from e-Bay to try my hand at fixing it.  This player has the “Load Main Image Failed” issue.

So far I have tried:

ChkDsk- No errors were found.

FAQ #2 fix, which I have tried numerous times.

These two fixes have not solved the problem.  Any suggestions on what else I should try would be appreciated.


reinstall firmware of format

Unless I’m mistaken that is what #2 of the FAQ does? Specifically, I have downloaded the .rom and .mi4 files and copied them to the 16MB root directory.  I have also placed a folder in that directory named sansa.fmt. See message no. 4 (c1u31355) of FAQ item #2

I have tried various combinations of the above process without any success.

Message Edited by Gecko10 on 06-13-2009 05:35 AM

try using the sansa firmware updater.

Did that. It won’t recognize the player.  Moreover the Version.txt file in the root directory says it has the latest firmware eg. 24

Have you done the recover mode “sansa.fmt” yet? Have you tried the Linux sansa fixer? (not sure what’s in the FAQ, too lazy to look at it… )

There’s no such thing as a bad experiment.  Well, at least in terms of an experiment with a plan.

Try this: do you get a successful Recovery Mode screen message on the player?  If so, hold on to your shorts.  Download this file from the SanDisk archives, 12a.  Run the program with the Sansa connected in Recovery Mode.

The application, when run, will find your connected Sansa and will install the base firmware on it automatically.

After the file transfers, you can unplug the device after sliding the HOLD switch back to the left.  It should give you a “firmware upgrade in progress” message.

See if the Sansa has come back to life.

After this, the device can be upgraded to 1.02.18 or 1.02.24 (the 24 version can be loaded by the Sansa Updater if you wish).  The base firmware has no custom EQ.

Let us know what happens!  Good luck.

One footnote: if the firmware will not transfer, remove the back of the e200, and press downward on the grey foam rectangle at the top of the player, above the battery.  The e200v1 has a socketed daughter board with the NAND flash memory module.  If this connection pops loose, the device cannot read the “main image” (firmware) from memory.

Bob  :smileyvery-happy:

Thanks Bob.   I was hoping you would respond.  I’ll give your suggestion a try and will post results.

Of course my thread subject should have been “Experiment on a Bad e260 V1.” :smileyvery-happy:

Message Edited by Gecko10 on 06-15-2009 04:05 AM

Bob. Ran the software as you suggested and the player did come back to life.  Went into the settings menu and made sure it was on MSC mode.  Turned the unit off.  Turned it back on and now have the Blue Ring of Death.  Sigh.

Can’t get the computer or the upgrader to recognize the device now, though when I plug it in I get the "Found New Hardware’ message and the “ding” sound of a USB device being connected/disconnected.

Try powering it all the way off then back on a few times.

 (HOLD the power button for 15-20seconds for a “Soft” reset.)

If that doesn’t work, try Bob’s procedure again. Sometimes these things are just stubborn…

Cool, perhaps Frankenstein may live again!

Our next step (keep trying) may be tinkering with the I2C ROM.  What activity do you see when the device is unplugged following the firmware transfer?  Autobahn is right, sometimes a repeat operation results in success.

Bob  :wink:


When I ran the software you recommended (.12a) the first time in the Recovery Mode and unplugged the player the player came back to life.  I went through all the menus, Music, Settings etc, just to look around.  Everything worked nominally.  Then I shut the player off and turned it back on.  That’s when the Blue Ring of Death Occurred.  Since then I have not been able to do anything with it, can’t even get it into the Recovery Mode.

I don’t have access to Linex and am not sure that the time and effort to get and learn it is worth it.

Message Edited by Gecko10 on 06-16-2009 03:52 AM

@gecko10 wrote:


I don’t have access to Linex and am not sure that the time and effort to get and learn it is worth it.

Message Edited by Gecko10 on 06-16-2009 03:52 AM

Linux is Free, google “Ubuntu” or whatever. You just have to download it, put it on a CD or bootable thumbdrive (if your PC supports that, in the menus BEFORE Windows starts up,) and use it…

Another Sansa means $$…   :frowning: