Audiobooks Download Problems - Overdrive

I have a 2 GB Clip and I can’t get audiobooks that I have downloaded from a local library system and I have tried using the Overdrive Console and it gives me an error saying “because [Insert3] returned OxC00D2772” does anyone have a clue what this error is? I have reinstalled the driver and i have changed my USB Mode to MTP and i still get this error. I have read the previous posts about using “Overdrive” and WMP11 with no luck.

Thanks Frustrated :frowning:


Uh…does Overdrive have tech support? Because I would find out what that error means before you do anything else.

I am having the EXACT problem and it is driving me crazy.  My housemate bought the same sansa a few months ago and has no problems… maybe it’s a problem with the unit itself.

Same exact problem here. Just purchased the unit new. I am going to email SanDisk Tech Support and Overdrive as well.

I had the same problem. I spent four hours downloading new drivers and trying the tips suggested by others, as well as everything I could think of. Nothing worked. I took it back, got another one, and it worked perfectly with Overdrive straight out of the box - just a few seconds to download my audiobook. Clearly the first device was defective. Your best bet would be to return your device for a non-defective one. I really like mine now that it works. Good luck.

What do I do with a 2GB Clip bought at Christmas time that was bought at target with a 90 day return policy? Has anyone had experience sending there clip back to SanDisk? Thanks for the responses.


OverDrive gave me a fix that worked. See below.

We apologize for the problems that you have encountered. This error is usually resolved by formatting the device from the device’s internal menu. To do so, please follow the steps below:

**Please note, the following steps will clear all data from your device.

Please back up any files you wish to keep prior to completing these steps.**

1) Make sure the device is disconnected from the computer.

2) Power on the device.

3) Select the 'Home' button and pressing down arrow, navigate to the 'Settings' Screen.

4) Press the center button.

5) Press down arrow and select/ Highlight 'Format'.

6) Press center button.

7) On Format confirmation screen select 'Yes'.

8) After format is complete, try to transfer an OverDrive Audiobook.

Please let us know if this helps or if we can provide further assistance.


The OverDrive Media Support Team


It is a little bit of a bother to have to reload all music and stuff but it worked.:smiley:

This worked for me, too. Also-- I was running an older version of Overdrive software on my PC, which trashed my Clip’s installed firmware. That problem was corrected using Sansa’s firmware updating tool. Once my firmware on my Clip was up-to-date, and the latest OverDrive software was installed (v3), I was able to transfer OverDrive books downloaded from the public library to my clip.

My clip worked great for about 2 months.  Then the problems started.  I did the recovery suggested and was relieved that I could download overdrive books without stopping our wireless access.  Then I received error messages when downloading.  An icon appeared that indicates it is safe to remove hardware.  Unable to access the internet wireless again.  Has anyone else had this problem?  Any suggestions?