Sansa Clip and Overdrive problem

I bought a Sansa Clip 2 GB to listen to audiobooks in Overdrive. At first the Overdrive didn´t recognize the player, but the latest firmware installation and changing the USB mode to MSC seemed to fix that problem. However, when I try to transfer the audiobook to the player, the program recognizes the player at first but then when it normally would transfer the book, it gives a message “the selected portable player (Sandisk Sansa Clip 2GB USB device (SANSA CLIP) could not be found. This process will be aborted. Please reconnect your device and try again.”

Would anyone know what to try next? Trying to set the player folder with advanced options does not help. Anyone?

I have the latest version of overdrive


I download and listen to OverDrive audiobooks all the time without problem.  The most important thing is that the Clip’s USB mode is MTP so that the license gets transferred over from the PC to the Clip.

Hope this helps.  Let us know how things work.

Thank you, I tried the MTP mode but got only a message “no portable players could be found”. 

With MTC mode the problem seems to be in the last step of the transfer process, until then everything works fine. It is only then that the system does not recognize the player any more. I wonder if the problem lies with the program or the Sansa clip? 

I had previously a Sansa m240 and used it without any problems until they upgraded the Overdrive Media program. 


Does your computer itself recognize the Clip in MTP mode or is it just the Overdrive SW that has the problem?

No, the computer does not recognize the clip in either MTP or autodetect mode, only MSC works. The same happens with Overdrive. I wonder if the problem lies with the computer or my Sansa clip? 

Are there any drivers for Sansa players that could be installed to the computer? 

It seems to be that the computer was the problem. I transferred the audiobooks without problems with my friend’s computer that has windows vista. Mine has windows xp. I still wonder if there is anything to be done with the computer? I would appreciate any tips what to do.

I don’t recall the particulars but there have been numerous threads where people have fixed similar problems.  Maybe search the forum for “MTP”?  Or enter a new topic with a good descriptive title of your problem and someone will spot it and help.

Good luck! 

What version of WM do you have on your computer? I think that it needs to be version 11.

I use Overdrive’s facility… the little player icon at the top of its window. Click the browse button and point to the Audio Books folder then download it there. Has worked fine for me so far with a dozen books.