Sansa Clip problem with security & audiobooks

Hi I am new to this forum and need help.

I have gone from loving my clip to being increasingly frustrated with it. I primarily use it to download audiobooks. I have never downloaded or used any software like Rhapsody. I have only ever used music I have ripped from my own cds on my own pc or books l have downloaded with overdrive from the library. Now I can play either none of the books I have downloaded from the library or only the first 2 segments at which point it will not play any of the rest of them but prompts me to sync to reset my subscription or most recently transfer title using audiobook software. I have had a 2GB clip for 18 months now. For 16 months no problems. I download lots of books from the library using overdrive and have played them with no issues. Over the last couple of months everything prompted me to download new versions of things from Overdrive software to clip firmware to internet explorer. Soon after doing all this I tried downloading a new book - no luck my clip was no longer recognized. For the next month I was able to listen to books already on the clip but not download anything else. I finally decided to do something about this and have tried pretty much every fix I could find with none of them working - here are most of the things I do know:

-I can sync to my pc - windows xp

-I have the firmware updater and on my clip it says that I have the firmware V01.01.32A

-My computer will recognize the clip as a MSC by simply plugging it in. I can force it in MTP to hook up - lock the power and hold down center button. But it won’t recognize it a second time with out doing it again.

-I have done the windows media player security upgrade in overdrive.

-I have reformatted several times with the clip in both MTP and MSC and on the computer with the clip in both settings. But all times I continue to have the error message that I need to sync or transfer title

-I have gone into WMP11 and gone to Sync>more options > privacy > and made sure that “download usage rights automatically when I play or sync a file” is checked and it still won’t let me listen once I download book fresh to overdrive and sync to clip.

-In both WMP11 and overdrives the properties say that they audiobooks are authorized to be synced to a device. Once I sync it the properties for the audiobook on the device say “protected content”

Can someone help me please!!! Shereen

Overdrive Media files need to be transferred to the Sansa using the Overdrive Media Console.  Download the client and use it to send the audiobooks to your Sansa directly.

As it’s protected media, the Sansa needs to be in MTP mode to transfer the licenses over as well.


Message Edited by microsansa on 05-29-2009 10:28 PM

I wish I could use it in MTP however I cannot do so. I can change the clip to MTP and force it to hook up by doing that trick everyone talks about. However I cannot use it in MTP. Even after forcing the computer to see it that way and re-formatting, downloading via overdrive, it will still not play audiobooks without the security notice. I do not understand this as I have downloaded audiobooks from the library webpage to overdrive on my computer and then used WMP for 16 months to download them to my clip with no problems.

How can I get the clip to be usable in MTP. I know how to switch it over in the USB options but I cannot get my computer to recognize it by simply plugging it in…

In another thread neutron bob was able to solve my problem. Thank  you for your assistance.

Hey Shereen,

Did you ever get a solution to your problem?  I received a Sansa Fuze for Christmas and have the same problem.  I can transfer a book using Overdrive and am able to listen to the first two parts and then get the security popup that says “Please obtain license by transferring this title to device using audiobook software”.  I deleted the entire book and transferred it again and now I can’t even listen to parts 1 & 2.  I downloaded another book and transferred parts 1-3 and am able to listen to part 1 & 2 and then I get the security warning on part 3.  This is becoming very frustrating.  I loaded several MP3 songs by dragging and dropping and so far they seem to work just fine.  It’s these audiobooks that are giving me a fit.  The computer won’t even recognized it in MTP mode. HELP!!!

I sure did. We just had a similar problem with my husbands and used this to fix it also. Go to this link:

and go to the last couple of posts. Fixed mine right up!

Merry Christmas.

I know it’s been a while since this was posted, but i just experienced the same problem and have found a solution.  You need to update the driver from Device Manager WHILE THE CLIP IS IN MTP MODE:

Put the Clip in MTP mode.

Connect it to the PC (the PC dosn’t recognize it, that’s OK)

Open Device Manager

In Device Manager, you should find the Clip displayed as not working properly.

Right-click the Clip and select Update Driver