SanDisk Clip and Overdrive

I bought a brand new SanDisk last week. I use it to listen to audiobooks I check out from the library. The library uses Overdrive. I can check out and transfer MP3 books but NOT the WMA books. The error messages I get talk about licenses and certificates and how I don’t have them. BUT I have zero problem transferring these same books to my old Phillips MP3 player and they work perfectly. I have read a bunch of threads about MTP and MSC modes and switching doesn’t help. I have tried to transfer the books using OverDrive and Media Player. Neither worked.   Bottom Line: Can my SanDisk Clip play the DRM WMA books or not? If not, I need to get my money back and I’ll keep using the old Phillips. , $34.95 from Amazon.

Yes, DRM-crippled .wma files from the library will work on your Clip+ or Zip (you didn’t say which you have). The player must be set to MTP mode (to allow the licensing keys to be transferred with the files) and the files transferred through the Overdrive software.

Note that by default the Overdrive software will place these files in the Music folder which leads to some confusion and prevents some of the audio-book features. You have to dig into the Advanced options (in Overdrive) to specify the path to the Audio Books folder as the target destination.

My Clip+ is in MTP mode. I get the 'no license" message when I try to transfer… My computer can see the clip and I can open it. I can get the books into Overdrive and the MP3 books transfer without issue but the WMA files won’t transfer to the clip. Unfortunately there aren’t as many books to choose from in the MP3 format. Any other suggestions?

Does anything here help?

There is one recommendation for a SANSA M200/C200 MP3 player. It says to use my computer to format the player. There aren’t any recommendations for the Sansa Clip which is what I have. Should I try to reformat the player using my computer? I have already used Format on the player and that didn’t help.

There’s no benefit to formatting via your computer if you’ve already done it with the Format function on the player.

There’s got to be something unique about what you are doing (or not doing) that isn’t giving the desired results. We’ve heard from many, many people over the years that have successfully transferred .wma files from the library to their Clip+'s.

You might try manually re-installing the firmware and resetting the clock and then re-authorizing the player through Overdrive and transferring again.

And btw, the m200 & c200 players are extremely antique these days. Your Clip+ is superior in just about every measurable and conceivable way.

This is just so strange because I have a 3 year old Philips MP3 player and the books transfer with no problem. I just wanted a new player because the buttons are getting a bit loose on the Philips. I just don’t understand why it works on the old one and not on the new one. AND BTW I have a service call #1519833. They were supposed to contact me this morning at 8.30 and I didn’t get a call back.