DRM problem with Audiobook loaded by Overdrive Media Console

Overdrive copied my audiobook to the clip but the files will not play.  I get a message about no license.  It behaves just as it did when I tried copying the files with Windows explorer.  The files play fine on my computer but not on the clip.


The Clip must be in MTP mode for the license data to be transferred using the Overdrive Media Console.  Also, Windows Media Player is needed in the background for MTP capability; it provides the MTP drivers.

On the device, go to Settings > USB Mode > MTP.

Try retransferring the book using the Console, and let us know how it goes!

Bob :wink:

Didn’t work.

 I changed to MTP mode, when I plug the clip into the usb port it makes a different sound than usual and the overdrive console can not find it.  I startred up Windows media player and minimized it - is that what you meant by  ‘in the background’? I did the whole process again with media player minimized - same result.  Also do not see the clip in the windows explorer display.  before changing to MTP mode, overdrive did see the clip and tranferred the files.

clip software version 01.01.32A


Windows Media Player does not need to be open.  It simply provides the DRM capabilities and the MTP framework.

Manually set your Sansa to MTP mode via Settings > USB Mode > MTP. 

Have a look using Windows Explorer, press [Windows key] + E or go to My Computer, then plug in the Sansa.  If it is talking in MTP mode, it will show up under Other as a media device.  This will confirm that the Clip is in the correct configuration.  Double click on the Clip icon, and see that Internal Memory first displays; another double click will open the root directory.  Then go ahead and close the Explorer window.

The Overdrive console can be a bit flaky. Correcting the problem may involve formatting the Clip, then retransferring your files.  Make this a last resort.  Let’s go back to Windows Media Player.

Transfer one song via WiMP to the Clip, using the Sync tab, then select a track.  After doing this, then close the media player, unplug, and see that the track plays.  Then try retransferring with Overdrive.

If this doesn’t change anything, then try the formatting method.  Before doing this, be sure that you have backup copies of your music, as formatting clears everything from the Sansa.

Bob  :smileyvery-happy:

When I plug in the clip in MSC mode i get a ding/dong sound and it appears under the MY COMPUTER heading in explorer.  When I change to MTP mode and plug it in, I get a ding/ding/ding sound and I can’t find it using explorer.  Where should I be looking for OTHER in the explorer display?  There is no OTHER category in the MY COMPUTER section.


Your copy of WMP needs to be version 10 or higher. I only use MSC mode. For the purpose of this post, I switched to MTP mode and plugged in. The computer recognizes the clip, offers to open a window to view files (together with the other options). My music folder displays empty, as it should since all my music was loaded in MSC mode.

So you should be able to get that far. 

When I use MSC mode, and plug in the clip I get a popup window asking what software to use.  I pick Media player and the audiobook plays.  When I switch to MTP mode, I do not get the pop up asking for a software selection and when I start Media player I see no trace of the clip files even though it shows files on my C and D drives.  No software sees the clip in MTP mode although XP does acknowledge that I plugged it in by the 3 sounds.  I don’t think MTP mode works.  I have 2 clips and MTP doesn’t work on either one of them.


I finaly got this to work - it was a bad windows driver apparantly.  When I reloaded the driver it started working!

When I had the same problem with 2 Clips, that should have been my first clue that itt was more a problem with my computer.

Thanks so much to those of you who responded to my posts with your wisdom.


I seem to be having the same problem.  The CLIP isn’t recognized in MTP mode and I can’t get audio books loaded from Overdrive to work.  Do you remember how you reloaded the driver in windows?