Overdrive Audiobooks Problem

I have two Sansa Clips+ and neither one of them is playing the audiobooks I get from Overdrive. I have:

  1. Upgraded to latest software

  2. Changed USB to MTP mode

  3. Downloaded the files into both Music and Audiobooks files

  4. Upgraded WMP security

Nothing I’ve read in these forums has help so far but maybe I missed something. Thanks 

Are you sending them through Overdrive’s own Media Console? You can’t drag-and-drop, and I don’t think you can use Windows Media Player. Digital rights codes are in use. 


Yes I use overdrive to transfer.

As long as you can transfer music or other data  to the Clip–so you know it’s not a cord problem–you can probably get better help from Overdrive itself.


Are they listed on the unit but don’t play? Do they show up in Windows Explorer as being on the unit but aren’t listed?

It seems like Overdrive makes the individual libraries host most of the help files, so you might input your library on Overdrive and see what you get.


It also seems there are different version of the Overdrive software in various locations. Very complicated…

Thanks for the advice :slight_smile: I just don’t have anymore time to waste on these mp3s however so i’m going to sell them and see if some other device will play WMA.

The Clip plays .wma. It even plays the copy-protected .wma files you get from Overdrive. But with copy protection in any player, every setting has to be correct for it to work. 

Copy protection is designed to cripple files. Hidden codes are sent through the (Overdrive) media console to un-cripple them. Maybe you’ll have better luck with another player, but you are still going to have to make sure Overdrive is set correctly.