Overdrive Audiobooks


I am not sure how to fix this problem.  I try downloading books from Overdrive and the books won’t play past the first two parts.  I’ve read various things that are suggested on these boards.  This is what I have tried:

Updated the driver in MTP mode.

Try to transfer the title using the Overdrive media console and in MTP mode and I get an error that says the format WMA audiobook is not compatible with my Sansa Clip

Any suggestions?

Did you read the posts about using Overdrive library system?  Do you have Windows Media Player version 10 or 11?

I asked the same question but had not tried MTP mode in the USB choices.  Once I switched the USB mode to MTP, everything worked.  Is your Clip the original or Clip+?  There shouldn’t be a problem since they are both listed on the Overdrive Media Console as acceptable.  Here’s advice from jj2me that helped me:

"Re: Using Overdrive (library system) and audiobooks

12-13-2011 07:26 AM - last edited on 12-13-2011 07:28 AM

I’ve never heard of this problem.   A digital rights management error might occur if you didn’t have Windows Media Player v9 or above installed, or didn’t load with a program that ties into WMP9+ (like doing drag-and-drop directly to your player).  But you’ve experienced a mix of good and bad–very odd.

The Clip/Fuze players are great with audiobooks.  Did you do the following?

  1. Load audiobook onto player using PC’s OverDrive Media Console program?

  2. Have WMP9+ installed (this secures the rights for the player, indirectly through a call to it by OverDrive Media Console)?

  3. During the OverDrive Transfer sequence, clicked on “Advanced Options…” and then ensure the book parts get put in \Audiobooks.… rather than the default location \Music.… ?  (This ensures you get the great resume function, not only for the last listened-to audiobook like your Nano Plus does, but also if you leave and listen to other content, it’ll remember your place in every audiobook and podcast.)

Step 3 has nothing to do with your problem, but it’s what we all have to do to get the resume function.

Step 1 could also be accomplised by loading via WMP, but most don’t do it that way (I’ve never tried)."

Maybe you need the WMP v. 10+ to help secure the rights for the player.  Another post mentioned I needed v. 10 or 11 and MTP mode to have the audiobook work properly.

1 Like