Using Overdrive (library system) and audiobooks

I’ve been downloading and listening to audiobooks from our public library for almost a year.  My old Zen Nano Plus has no problems with these books.  Since I just got a brand new Clip+, thought I’d try out audiobooks on it.  The library has you download books in parts, usually 6-10 per book.  I downloaded a book and listened to the first 2 parts.  The next day, when I tried to listen to another section, nothing would play except the first 2 sections already heard.  The other sections had a message about digital rights or something.  I already erased the book so can’t remember for sure.  I’m wondering if this has happened to others? 

I think I read something about Audible books having a problem.  These are public library audiobooks, not listed as Audible.  My Zen player never has a problem.  Is this an issue peculiar to Clip+?  I will just put books on my Zen and use the Clip+ for music.  I had downloaded my audiobook into the audiobook folder, if that makes any difference.  I thought about downloading again (still didn’t help).  Maybe if I listen to a bit of every section before turning it off, it would let me listen to all sections on different days?

Any suggestions for getting around this issue?  Thanks

I’ve never heard of this problem.   A digital rights management error might occur if you didn’t have Windows Media Player v9 or above installed, or didn’t load with a program that ties into WMP9+ (like doing drag-and-drop directly to your player).  But you’ve experienced a mix of good and bad–very odd.

The Clip/Fuze players are great with audiobooks.  Did you do the following?

  1. Load audiobook onto player using PC’s OverDrive Media Console program?

  2. Have WMP9+ installed (this secures the rights for the player, indirectly through a call to it by OverDrive Media Console)?

  3. During the OverDrive Transfer sequence, clicked on “Advanced Options…” and then ensure the book parts get put in \Audiobooks… rather than the default location \Music… ?  (This ensures you get the great resume function, not only for the last listened-to audiobook like your Nano Plus does, but also if you leave and listen to other content, it’ll remember your place in every audiobook and podcast.)

Step 3 has nothing to do with your problem, but it’s what we all have to do to get the resume function.

Step 1 could also be accomplised by loading via WMP, but most don’t do it that way (I’ve never tried).

Another thing to try - on your player go into Settings|System Info|USB Mode and switch it to MTP.  You may need to retransfer the books in MTP mode.  I use my Clip/Clip+/Fuze players almost exclusively with Overdrive (and mine work in MSC mode, too, but MTP is supposedly “required” so it’s a good thing to try). 

Thanks for your input.  I did use the Overdrive Media Console to download my book, have WMP 10, and used the advanced option when downloading from Overdrive .  I haven’t tried MTP in the USB mode because it isn’t recognized by my computer.  MSC works fine, but when I try MTP, then my computer can’t “see” the Clip+.

I’m not too concerned as I can still use my Zen Nano Plus for audiobooks, but was hoping it would work on both players.  Sometimes when an audiobook is due, I can leave it on my player until I finish listening.  I always erase when I am finished with the audiobook.  I’ve been using the 7 day checkout rather than the 14 or 21 day, so that others can  have the book quicker.  We can’t return audiobooks early like you can an ebook.

I downloaded a new mystery to the Zen and may try again on the Clip+ just to see if it was a one time glitch.  Thanks again.

Well, I tried downloading a different book that worked fine on my Zen player.  I had the same thing happen:

Downloaded through Overdrive Media Console, used advanced option to transfer (Audiobooks file).  I can listen to the first 2 sections, then the rest of the sections show this message:

Please obtain license by transferring this title to device using

The rest is cut off and when I try to see the rest, I get a blank screen with dotted lines at the bottom.  My player acted funny, so I deleted the book immediately.  It’s a mystery to me.  Am afraid to try MTP mode since all my music is in MSC mode and I don’t want to lose all those tunes if the player has to be formatted because of glitches.  My computer is an old Dell with Windows XP.

In general, make sure you music is backed up else - just in case you ever need to reformat!

If you want to pursue it further, start with a freshly rebooted computer, switch the player to MTP, plug it in, and look for it under Device Manager in the Control Panel.  Hopefully(?) it will display with an error & you can update the MTP driver.  Good luck!

I only do 7 day check-outs, too, just in case something better comes along.  I’m sort of an Overdrive junkie - have to go there everyday just to see if there’s anything new since yesterday!

You need to be in MTP.  “Auto” USB mode should also put you there.  MSC will not work in transferring rights.  Your Zen Nano Plus is constantly in MTP mode.  You shouldn’t lose music on the player due to changing the transfer protocol.

Try another USB port; if you have a desktop, try one on the back panel.  If still no go, then do as kmk_01kmk suggests.  You have no other choice but to get MTP working if you want to listen to local library protected WMA audiobooks on your Clip+.

I believe the Overdrive system is happiest with MTP, is it not? Especially since the Clip’s unique ID and secure clock are needed for the DRM system (WMDRM-10).  This is only available in MTP mode.

Check your Windows Media Player installation.  Windows XP came bundled with Windows Media Player 9 ,which does not support MTP transfer.  Open WiMP and click on Help > About to check your WiMP version; I’ll bet that you still have version 9.

There are two routes for you, the best is to update Windows Media Player 11 (the interface is smoother than 10, but either version is OK as they support MTP.

The alternative is to look up the MTP Porting Kit from Microsoft (free download for XP).

Note that the Overdrive Media Console is still used to transfer the books to your device, MTP support is added in the background via Windows Media Player.  With Auto Detect active (default on the Sansa), it will connect in MTP if available.  For your books, at the least, I would select MTP mode on the device.

Regardless of the USB mode used for transfer, both your audiobooks and any music transferred in either MTP or MSC can be accessed from the player itself, so you won’t need to erase anything.

Overdrive actually uses an earlier version of the Windows Media DRM, so it can do some quirky things in the current DRM-10 environment (it’s backward-compatible).  This is why some tracks may actually play, and others give the general DRM error flag (the “synchronize” message.

Bob  :smileyvery-happy:

Thanks so much for your clear and detailed advice.  I guess I’m afraid to tinker too much since the player is working so well with the music.  I’d never heard about MTP, MSC, Auto Detect, etc. until I started reading this forum.

My Windows Media Player is a version 10 (double checked). Guess I can bite the bullet and try downloading the audiobook again using MTP mode.  Will let you know later if it works.  My music is in my Music Folder on the computer, just in case.  If I download the audiobook in MTP mode, do I have to switch it on the player when I listen to the book, then switch back to MSC if I want to download music?

Thanks again everyone who helped.  Worked like a charm when I switched to MTP mode before downloading the audiobook from Overdrive Media Console.  I tried 4 sections and all worked fine.  My music works fine too.  Who knew?

Hope this helps anyone else who was having problems with audiobooks from the public library.  Can’t say enough for listening to audiobooks from our local library.  Since my dogs need to be walked every day for about an hour, music and books really keep me motivated.