mtp / mcs / Overdrive Media player issues

I had to switch my clip to mcs to get it to talk to my computer.  It was able to use mtp mode, but I think (not sure) that it stopped after I upgraded Windows Media Player to version 11.  Now I have a problem with the Overdrive Media player.  It downloads the audio books just fine, but the player will play a couple of parts and then for the rest say that the player needs to synchronize with the media player.  So, I contacted Overdrive and they said the following:

We are sorry to hear that you are having trouble listening to our
titles on their Sansa Clip. The error message you are receiving is
often caused by a USB setting being changed during transfer. Our titles
are DRM-protected files and must be transferred in MTP mode. There is
another mode, MSC, which allows them to save any data on the device and
also transfer non-encrypted music and audio books. With the Sansa Clip,
these modes should change automatically.

So, how can I get my computer to recognize the player in MTP mode?  Another computer will do so without any problems.  Do I need to revert Windows Media Player to version 10?

Thanks for any suggestions.

Not sure if this will help, but maybe you need to do the security update again in Overdrive.  Tools menu, select “Windows Media Player Security Upgrade…”.

Just tried that.  Unfortunately it didn’t work

Just tried rolling back Windows Media Player to version 10.  Didn’t help.

Check the Clip’s Settings/USB Mode and make SURE it is not set to MSC mode. It should be set to “Auto” or MTP in order to do what you need…

If set to MSC mode, change it to Auto 

When I set it to auto, the computer will not recognize it.  Says it needs to install hardware for a MTP device, which it won’t.  Quite annoying.  Can’t figure out how to get the computer to recognize the MTP device.

Plug the Clip into the back USB port. 

Uninstall the MTP device in Device Manager and refresh. 

See if this helps. 

Tried uninstalling and refresh.  Didn’t work.

Hi Old Geek,

I found this post this morning, typed the command as written, and now my Clip magically appears as an MTP device on my Home computer.  My workaround to date had been to connect and transfer Overdrive books on my Work PC as my Clip always popped up in MTP mode there w/o a problem.

I hope this fix works for you, too!