Another computer won't recognize thread

I have tried connecting this thing to every USB port on my computer, all 6 of them.  I have the latest firmware on my connect as well.  I don’t use WMP or Jukebox or any of that stuff, all I do is open the file folder and drag and drop.  It connected just fine a few days ago and I have changed nothing since.  When I go to the device manager and look under portable devices it says “Sansa Connect” with a yellow exclamation point next to it.  When I click on it, it says "Device cannot start (Code 10), I then click on check for solutions and it says “Could not load driver”  I’m just trying to see if my can find a solution to this problem without using the recovery tool.  Thanks for any suggestions.

Check the version of your WMP. MTP drivers are built into WMP 10 but further refiened in WMP11. I’d also also try performing a complete restart of the player befoe connecting the device. If not try uninstalling the connect then reinstalling it. You might need some other hotfixes, just let us know how that turns out.

I think Microsoft is stating this to be a general driver failure.

Check out this link for discussion.

There is no Sansa Connect’ driver per se, since Sansa players just use the generic MTP driver installed by WMP.

I’m still trying to research this problem which wasn’t affecting Sansa Connect until you reported it.

I’d start with uninstall and reinstall WMP 11. Also check for updates.

Try after complete restart of Connect also.

Try also advice from mysansa67 in this post:

review all his posts

I wish I could but on Vista there is no way to uninstall WMP 11.  I have also tried the recovery tool but it will not work as well.  If my understanding is correct, you hold down the right button and the volume up button and then press the power button correct?

Message Edited by jojimbo15 on 02-04-2008 08:17 PM

That is correct sequence to initiate recovery mode, be sure to start from full power OFF.

It won’t go recovery mode from SLEEP.

Just used the recovery tool and my computer still won’t recognize it.  I think it’s got to be something wrong with WMP which I have no idea how to fix since it can’t be uninstalled on Vista.  I emailed SanDisk but still haven’t heard a reply back yet.

Vista has a known issue where it will not be able to find the proper driver.  You can look here for more information and a possible fix for your problem:

Message Edited by drlucky on 02-05-2008 10:24 AM

Thanks, I’ll give that a shot.