Please connect your player.

Uninstall, reinstall, reboot, boot the Connect first, launch Media Converter first, run in compatibility mode, disable most everything in the startup list via MSCONFIG, use Media Converter to reformat video and try to use Windows to transfer to the Connect…

Nothing.  Nothing works at all.

Sansa Media Converter does not and will not recognize my Connect. 


Time to call Tech Support.

Sorry to hear that.

Try connecting it after opening Sansa Media Converter.

I mentioned above that I already tried launching SMC first.  'Fraid it isn’t that simple.

I’ve tried it on two computers now and SMC does the same thing on both.  A Reset & Erase of my Connect might do something, but I’m not sure if I want to bother.   I was just curious to see it work. 

I haven’t had the level of issues you have noted, but I have noticed on mine that I sometimes have to reboot (not reset) my Connect in order for Media Converter to see the device.

Does Windows see your device, i.e., can you see it in Windows Explorer?

Yes, Windows recognizes the player.

There’s no way to change the transfer mode on the Connect, right?

Windows should ask you which program to open your Sansa Connect. You should see the Sansa Media Converter

as one of the option. If not, you should reboot your player and PC.


Are you using Windows Media Player, and if so, what version?  WMP11, an early version, has a bug in the MTP driver, which SMC will also use and is needed for any Sansa Connect communication.  One way to tell if you have the buggy version is to open Windows Explorer, Click on the Sansa Connect device (it isn’t a drive letter because it is MTP), then click the Internal Memory icon.  If you can see your music files, then your driver should be okay.  You might try checking for updates to WMP11, to be sure you have the latest MTP driver.

If that doesn’t solve, then I’d say a call to Sansa Tech Support is in order.

My mistake - sort of.

Since I used to own an e260, I already had Sansa Media Converter installed.  I launched it and did a Check for Updates and there were none available, which made it sound a LOT like I was using the latest version of SMC.  True, but it’s the latest version of SMC from ArcSoft.

You need to use the Sansa Media Converter 2, written by InterVideo.  The FAQ just says that you need to use Sansa Media Converter.

This would’ve been much easier if Sansa made the link available without forcing you to register and remember yet another login name and password.

Yes. You do need the latest SMC. The link is provided in the FAQs.

Note the FAQs have been updated with information for the new v1.1 firmware. Well worth reading.

See, there’s the problem; you don’t just need the latest version of SMC.  You need the latest version of SMC 2.
I have the latest version of SMC and it doesn’t work.