aaaahhhhhh!!!!! my screen goes black if i touch anything

Please ive tried resetting my fuse. Nothing When i turn it on, the screen goes black when i touch the wheel or the buttons. then i have to wait a few seconds and it comes back on,  touch a button, off, wait ,on.  Please someone i love my fuse. help
Message Edited by Reeser on 05-11-2010 05:52 AM

It does look like your firmware got corrupted.

I would have tried to install a new firmware - just download the latest, drag and drop the firmware file on the Fuze icon in My Computer, pull the Fuze out and wait untill it updates itself.

After that it would be wise to format your Fuze using the Fuze utility inside the System settings options.

The link to the latest firmware is at the sticky at the welcoming screen of this forum. 

You can try re-installing the firmware as suggested, but it really doesn’t sound to me as if it’s a problem you can solve by that (or any other user-generated procedure). It sounds more like a hardware-related issue. Best to call SanDisk Tech Support; they can set you up with a replacement if it is and still under warranty.