90 mb, and it wont read?

Im am receiving an error message stating Not enough space for music DB. Plese free 90 MB. What does that mean. My mp3 player will not do anything.
When I connect it to the computer, it doesnt read the device, only the external memory.

Any help…?

Edit: and, when I checked the device’s files, none of the music from the fuze shows up, only the stuff from the external memory. But on rhapsody it says it has no space left. 

Message Edited by MrWingman on 08-28-2009 04:14 PM

And the plot thickens, the device wont turn on so I can format, just gives me the error message and turns off. WMP recognizes it and says its full, but it also says that theres no music on it.

annnnnnd, I tried to sync it, by deleting all the files. It says it did that but thats its also filled. I just dont see where the files are. They arent anyywhere in the device files. 

Seriously can anyone help?

Message Edited by MrWingman on 08-28-2009 04:54 PM

Have you read the FAQ that concerns this very issue?

I hadn’t, but that still doesnt tell me where my 8 gigs of music are, or how to delete the files on my fuze that wont delete.

You have a bad file or files that are confusing the Fuze. Those are the files you can’t delete. If Error-Checking fixes the file, you’ll be able to delete it and see your good files again. Try it, you’ll like it.

If it doesn’t work, you’re going to have to Format and copy back all your music again–you do have backups, of course. This is the surgical option, before nuking the whole thing.  

@mrwingman wrote:
I hadn’t, but that still doesnt tell me where my 8 gigs of music are, or how to delete the files on my fuze that wont delete.

Right now, you have file(s) that are corrupted to the point where they will not delete. Running ChkDsk will repair them to a state where you will be able to delete them.

Although, at this point and with this degree of corruption, I would opt for a format of the entire memory & clear it out completely. Formatting will also optimize the memory allocation clusters for best performance.

Yeah I ran it and it deleted my entire memory.

Now I just want to know what corrupted all of my files. 

Probably the ID3 tags in the most recent music you added.  The Fuze is picky–too picky–about tags. Things like unusual characters (foreign letters, non-Windows encoding), giant Comments (perhaps with embedded album art) or other unknowns can mess up the database.

Read about ID3 tags here. Then download mp3tag from the link in the FAQ and use it to standardize your tags with the settings in the FAQ. It takes seconds per album and eliminates countless annoyances.  

Actually, I hadnt added music in a few days. I plugged it into my car, working fine. Take it out, working fine. GO to turn it on an hour later, and I found it like that.

Well, somehow the database file turned unreadable.  Could be a bug, could be a glitch, could be a bad ID3 tag, could be ultramicroscopic data-eating nanospiders now being developed by DARPA–but now that you know that you’ll have to be eliminated. Sorry.