not enough memory for Music DB?

 “Not enough space for Music DB please free 90MB”   This is what my mp3 player says yesterday it was working and now its not please help me i need to jog tomorrow lol…

This is why there is a Search box.

You put on a file the Fuze doesn’t like. If you can connect, try taking off your most recent additions.

Or you may have to nuke it. Settings/System Settings/Format will remove all your music (so make sure you have other copies) and then you can reload everything but your most recent files. 

ok when i plug it in i go to computer and there is two removeable disk  G:  and F:    i try to open both but  F: says application not found and G: says to insert something into it.    and when i turn it on it says blah blah music DB and it turns off so i cant get to the menu what do i do now

Turn the unit off. Push the Hold (power) button up to show orange. Hold down the << and connect. This should force the most reliable connection, MSC.

Now look for SANSA FUZE (F: ) in Windows Explorer. [(G: ) is the slot for the MicroSD card.] Right-click on F. and try this: Go to Properties/Tools/Error-Checking and run that. If it finds anything, try disconnecting and see if the 90MB problem is fixed. A corrupt file can cause that problem, and sometimes Windows can fix it with Error-Checking. 

Otherwise, connect again the same way, right-click and Format… to FAT32. 

Message Edited by dudewtfwc on 07-07-2010 01:33 PM

ok i formated the device to what you told me now i can get the menu but no music.  i have a back up usb for that so no worries.

but when i plug it in to the computer i cant put the music back beacuse F: still cannot find application and it says removable disk not SANSA FUSE like it should

ok its working now thank very much now i can run in peace.

ill tell you what i did and the other people that might have this problem

i pluged it in after i formated it, it still said removable Disk F: so i clicked it once then right clicked it went down to “Open as portable Device”

and there was my mp3 player thank you so much.

Now that you’ve got it running, change Settings/System Settings/USB Mode to MSC. Auto Detect isn’t reliable.



I’m jumping onto this thread as I have a similar problem, however this solution isn’t working for me so I’m hoping for further help :smiley:

Firstly, my OS is Mac.  I’ve been receiving the “not enough memory for Music DB” error message and before I learned the problem is a bad file, I tried simply deleting 100+MB, however I still received the same message.  Now my mac isn’t recognizing the fuze, though, so I can’t go into the systems folder in order to reformat it or take off the offending files.  I have tried to reset the fuze using the instructions online, however I continue to receive the same error message.  If anyone can help me to reset, reformat or provide a work around for my mac to recognize my fuze player, I would surely appreciate it!


The Fuze may have slipped into MTP mode, which won’t connect to the Mac. With the unit Off, put on the hold switch (orange showing), plug the USB cord into the computer, hold down the << switch and connect. That forces MSC mode, which your Mac should recognize. You could try taking off the rest of your files that way–or start by taking off the most recently added ones, which may have had the file that made the Fuze go nuts.

But do NOT reformat from the Mac. The Mac filesystem is different and not for the Fuze. If you can’t solve the 90MB problem by removing files, then find a Windows friend, force MSC mode to connect and Format to FAT32 from Windows.