8GB Fuze not recognised any longer

I bought one of the 8GB fuze about 3 months ago and have had nothing but smooth sailing till last week.

i have been running the 01.02.28 firmware in MSC mode as my library is all vorbis and I use a pair of cans, however i added some FLAC files to the device early last week and then after a couple of charges (via my win XP box USB) the player started misbehaving. though as it was fine and played back all the FLAC perfectly I’m not totally sure that is the issue

Upon plugging in the player the normal connect screen came up, then it changed to switching between read\write for a couple of minutes, then finally it gave the 90MB Music DB error. in “My Computer” at the same time the drives appeared as corrupted, then almost instantly they disappeared and windows threw up a message saying the USB device has malfunctioned.

the player now starts showing the music DB error, it can be forced to go to the refresh media screen where it locks up by using “hold” and << and when plugging it into the PC nothing can be done as it says the device has malfunctioned. using the hard reset also appears to do nothing

I have also tried the device on my mac to no avail, as well as using friends cable/player and have verified that my cable works and that another working one does not fix the issue.

the only way I can now think to salvage the device short of sending it back for a replacement is disassembly and adding a JTAG to the board, however as it reasonably new it’ll be sent back unless anyone has a bright suggestion for something i haven’t tried?



Format and start over.

how do i format when i cannot get past the refreshing media or the music DB error and the unit is not recognised by any machine?

Have you tried the forced MSC connection?  Your post mentions something like it but is not clear. 

Unit powered OFF. Hold switch on. Connect while pressing <<.  Format in Windows Explorer if you can.

The 90 MB message is usually a tag or file the Fuze can’t handle. But it’s also possible the memory is malfunctioning as hardware, so if you can’t format and you’re still under warranty, call 1-800-SANDISK to repair (probably replace) the unit. 

yes, have tried forcing MSC (and i use that mode by default) to no avail, it just pops up a “usb device has malfunctioned” whenever i connect to PC

given i’m in the UK i should be fine to return to point of purchase for replacement as i’ve only had the unit for 3-4 months?