16GB micro SDHC Card not working


i just bought this 16 GB micro SDHC card for my Sansa e280v2: http://www.amazon.com/SanDisk-SDSDQ-016G-A11M-Sandisk-16GB-Microsd/dp/B001F6YRNO

I have Rockbox installed and when I first put the empty card into the player and turned it on, Rockbox displayed "<microSD1> in the file viewer

Later I connected the player to my computer and put with Mediamonkey some music on it. Everything worked fine until suddenly the connection got lost and the computer couldn’t access the card.

Also Rockbox doesn’t display it anymore.

So I went back to the original Sansa firm (03.01.16f), but still the same. Without Rockbox it doesn’t even boot when the card is inside.

What is goiong on? :frowning:


Could be the card, could be the unit. Try the card in a card reader or some other gizmo that takes microSD.

ok, I’ll try that, though I first have to find someone with a device that can read micro sdhc cards…

If it’s broken I’ll send it back to Amazon and get a new one which hopefully lives longer than 10 minutes :neutral_face:

You should look into one of these wee beasties.  The little MicroMate microSD card reader (center of the page) is the teeniest reader I’ve seen, and goes anywhere.  As you’re running Rockbox, having a handy card reader is a wonderful thing.

The card reader allows instant access to your cards for testing or transfers.

Bob  :smileyvery-happy: