Won't start if card in slot - quits while "refreshing media"

My Clip Zip is a 4GB and I have an 8GB microSD card in it.  I used it for a few months with 3 folders of songs in the Music folder on the card.  I added the songs while the CZ was connected to my Mac by USB cable.   The USB mode is set to MSC in the Settings.   The songs were added simply using the Finder to create a new folder inside Music and dragging the songs into the folder from the Mac directory.  iTunes was not used.

That worked fine, for a while.

This week I made 4 new folders and added songs the same way.  Now the CZ comes one, begins refreshing media, then shuts down.  I have to hold the power key down for 20 secs, then press once to get it to come on again, but the same thing happens.

If I connect it to the computer it comes on and I can then see what is on the card - which is everything I expected to see. 

So, I took out the card, backed up the music files to the Mac HD with the card in a card reader.  Then I reformatted the card FAT using Disk Utility on teh Mac.  With the now fresh card in teh CZ slot it does start up all the way.  So I tried making the folders again and copying the songs back into them.  I now have the same problem as before - the CZ shuts doo=wn during media refresh and has to be reset.


1.)  Why?

2.)  Is there another way to put songs onto the card from a Mac that is fool proof?

3.)  Can the card be formatted by the CZ?  It seems like that might help, but the option did not apprear when I put in the empty card, as I said above.  How to do it?

It has been over a week and there has not even been one reply, much less an actual suggestion?

I noticed that I did not say what kind of music files I was putting in the 4 new folders.  They are AAC files made from importing tracks off of CD’s into iTunes - in case that is important.  I’m pretty sure I have used AAC files before, but they might have been directly copied rather than exported from iTunes.

Hey, is there and award for the most difficult problem posted this Month?  :slight_smile:

This is essentially what’s been happening to me - and the reason why I’m now methodically going through every forum topic looking for an answer.  So far I’ve come across 5 areas of potential solutions (in addition to the protocols you’ve followed) which people have been recommending for various cures:

  1. Standardize tags using ID2v2.3 ISO-8859-1 format (eliminate large art work, comment fields, foreign characters, etc.)
  2. Update the CZ firmware
  3. Keep the playlist down to < 5,000 tracks (for database management purposes, I guess)
  4. Keep the total size closer to 16 GB rather than 32 GB (also for database management purposes)
  5. Install the Rockbox firmware to replace the CZ firmware.

I’ll continue to search to the end of this Forum’s (presently) 38 pages before I try any solutions.  My story: 

Bought a 4 GB CZ on Mother’s Day, 2013 for my 89-year old Mom, loaded it up with nearly 4 GB via Windows as per manual’s instructions.

Prepping for her 90th birthday next week, last week I attempted to load up a 32 GB (Class 10) SDHC micro-card with about 21 GB using my Mac and a card reader.  The (mostly) mp3 files were in subolders within folders: Artist > Albums > tracks.  Upon insertion, I got that “refreshing media” then quitting behavior.  Erased the card, tried loading it up via the CZ connected to a PC - transfer worked, but it turned off again while refreshing media.  I discovered here the card needs to be Class 4 or slower.  Got a 32 GB Class 4 at Radio Shack (SanDisk), put about 19 GB on it via Mac and card reader - this time with all mp3s in the card’s root directory (having used a file renaming utility to rename all the files in this format: “artist – album – track name.mp3”).  I inserted the card - the CZ turned off while refreshing media.

After multiple reboots and resets, it finally quit turning on altogether, and the PC reported that the USB device was unreconizable.  I bought a new CZ two days ago (1/2/14), but am going to learn all I can here before attempting any card loading.  I did plug the new one in to my Mac to top off the battery.  (I’m curious why it then reports “transferring”, as well as “connected.”  What’s that about?)

I wish someone had answered this question; I hope it was asked and answered somewhere else in these 38 pages.  Anyone know how I can tell what firmware version my CZ has?  I’d rather not go through the firmware update procedures if I don’t need to.

Seems a great device - on paper.  I’m hoping once it gets working right, it really is.

Thanks everyone/anyone. And Happy New Year!

Why is SanDisk not addressing this problem? This is a new mp3 player for me. I am trying to get away from the Apple Ipod zombies. My first day with this (including a new Micro SDHC 16GB card) and this is the first issue I have? I load the card - place it in the new player and next I am spending hours online trying to fix a brand new item? How shotty could this be?

Needless to say, I am furious. I checked troubleshooting - rebooted, formated and did the firmware update. Still…the second I put a card in…gets to about 50% and then goes dead as a doornail. 

I want someone from SanDisk to fix this issue and address the concerns I am having as well as these other users. 

If not - I dont see myself supporting this company much longer. 

Thank you,


Ok, fellas. I think I got this figured out finally. Hope this helps you as much as it did me. 

After my last post, I am sure you read that I did everything humanly possible to this thing to get the card to work. 

I ended up formatting the player and formatting the SD card as well to make sure that I was literally starting with a clean slate. Long story short, my final ditch effort to get this thing to work was to have them both cleaned off - I put the SD card into the card slot and then connected the player (with card inserted) to the computer. Going through ‘My Computer’ and selecting the Clip Zip it pulled up the ‘External Card’ and ‘Internal Memory’ as options. 

I put my most listened to music (only about 5 albums for a test run directly into ‘Internal Memory’)

The rest I manually selected in album form and moved all to the ‘External Card’ option (about 10GB)

After it running for a short time it offered me a format issue resolution. I am guessing a big part of the problem loading the SD card the way a normal person would - was causing acceptance issues with some formats the music comes in. I selected the checkbox to automatically format the music to acceptable files by the player and let it run…

After about 2 hours of it processing and placing the music on the player, I can say it successfully works. At this time the card has about 10GB and the player just shy of 4GB and it seems to be running just fine. 

Hope this helps since I found no reasonable resolutions posted. 

I am glad to help if needed, I will keep an eye on the thread for the next handful of days. Want this player to work!! I will tell you - even though I am exhausted with this thing at this time. Putting some of the music on with a decent pair of headphones - it does have great quality. I have all my EQ settings to rock and the sound is no less quality than a several hundred dollar Ipod. 

Either way - Happy New Year to all of you and best of luck!