Windows Media Player and Fuze

When I plug my Sansa Fuze into my computer I can play very few songs.  The play button is not greyed out.  I can play all songs in My Library.  I tried changed network options to no success.  Any solutions?


Songs can be put on the Fuze in two USB modes (Settings/System Settings/USB mode).

MSC treats the Fuze as two generic disc drives (the second one is the microSD card lot).

MTP makes the Fuze a drive to be controlled and synched by Windows Media Player, a la iPod and iTunes. 

Your computer can only see songs that were transferred in one mode at a time. Can you not see the songs? Or can you see them but they won’t play?

If you don’t see them, change USB mode.  Or look for them in Windows Explorer (Computer or My Computer, Explore inside the Sansa Fuze drive) and click directly on the file to play it.

I was always able to see all the songs.

In the MTP mode the play button is now shaded out.

Going back to the MSC mode asked me to re-sync my device and now tells me there are no files on this device and to sync files to the device.  However, my MP3 player is 8GB and it shows that there is 883MB left. 

When I navigated to My Computer>Sansa Fuze (E:)>Music the folder is empty.

Going back to MTP mode once more time, Windows Media Player shows the MP3 device with all the songs.

When I navigate to My Computer\Sansa Fuze 8GB\Internal Memory\Music all the artist folders are there with all the songs.

Yes, the computer can only see MSC or MTP.

So you’ve sent the songs over in MTP.

If you see the songs, have you tried highlighting them to see if you can then play them?

I don’t use MTP mode and Windows Media Player myself. I like to drag and drop with MSC and have control without automated stuff like synching that changes folder names and, unless you’re careful, dumps stuff onto the unit that you didn’t want to send.

Note that synching matches your Fuze to what’s on your computer. If you send an album over, delete it from your computer and then Synch, WMP will delete the album from your Fuze.

If you can’t make it work, I would suggest starting over. Make sure you have copies of all the music on your computer. Disconnect the Fuze and go to Settings/System Settings and Format the Fuze, erasing everything you’ve added.

Then put it in MSC mode and drag-and-drop your music. You can still connect it to your computer and play songs from it, like any other hard drive. 

I tried to copy and paste all the songs from MTP mode to MSC mode however the paste feature is greyed out,  I will have to paste all the songs on to my external hard drive and then drap and drop them all into MSC mode and hopefully that works. 

If you left the default settings in Windows Media Player, and ripped your own CDs, you may have added copy-protection to the files. Who are they protected from? YOU. You are prevented from moving them from drive to drive.

If they keep giving you trouble you are going to have to go back to the original CDs and rip them again–this time after going into the Settings of WMP and making sure they are ripped to .mp3, which does not have copy protection.

The copy-protection is unchecked.  I was able to move some of the music files from drive to drive.  They are ripped in .mp3 format.  When I go to WMP the same message appears "There are no files on this device.  To begin, sync files to the device.   However, when I navigate to My Computer>Sansa Fuze the music files are there. 

OK, you’re starting to get me confused.

Are the files now on the Fuze via MSC mode? Then WMP won’t be able to find  them because it is looking via MTP.

But if you navigate to the files via Windows Explorer and click on an album, you should be able to play it with WMP, just as you could play any other mp3 files on your computer.

As I said, I don’t use WMP. But I expect that once you play the files from the Fuze, WMP will add them to its library.

I think he was copying from mode to mode with 7Gb of music files and only 8gb memory on the device, at which point only 1/7th of the songs would copy… my 2 cents.

Yes, ehummvee you are correct I was copying from mode to mode, however, even 1/7th of the songs that copied over didn’t play in WMP.

The files are now on the Fuze via MSC mode.  I can navigate it via Windows Explorer and play it on WMP.  I want to be able to play the songs when the Fuze is plugged in to the USB player.  I still get the message of there are no files on this device and to sync files on the device.

You’re trying to play them from a “USB Player”? Maybe that player only works MTP mode. I thought you were trying to play them from your computer.

Really, I suggest you put all the songs in one place off the Fuze. Format the Fuze (under Settings/System Settings) to erase all the music and put it on again in one mode: MTP, I guess, because you want to sync via Windows Media Player.