WIll not turn on

I have a Sansa Clip 2G for 2 months that has stopped working
When connected to USB port it turns on and shows communication

Battery is charged

I can access via computer

When unplugged it turns off and  will not turn on




I have 3 units, one dying at 2 months is not very encouraging

With the Clip connected to your computer, Right-click on the Clip icon in Windows Explorer then click on Properties. What percentage does the battery charge indicator show?

Do you have an AC charger (wall charger) that you can plug the Clip into? Many cell phones come with a compatible wall charger.

When you plug your Clip into the wall charger, does the display come on?

Can you play anything while it’s plugged into the wall charger?

Does the battery charge indicator flash while the Clip is plugged into the wall charger?

When clicking on Sansa icon all I get is “open”, Explore", or Format

The battery charger shows full

Do not have AC charger

The other 2 units I have work properly on this computer USB port

No “Properties” when you right-click on the Sansa Clip icon. This is in Windows Explorer, right? That’s odd. Anyone else experience this?

Next I was going to ask you if you’ve installed the 1.01.18A version of the firmware to your Clip. This, along with a more accurate percentage of battery charge, would show in the Properties box.

Without being able to confirm your firmware version, I’m out of ideas for now. Sorry.

No Properties

When the Sansa Updater comes on it shows version 1.01.11

Can not update

Tried but to complete update need to disconnect

When disconnected the unit is off and won’t go in…as the title states

When I reconnect it shows again 1.01.11

Tried teh 15 sec reset . Also no luck

hi there,

If you do not have an AC charger, here is how you can simulate an AC charger using your cable with your PC…please use the method as described so that you can upgrade your device to the latest firmware which would hopefully solve some of your problem.


I have the same problem my clip won’t turn on but it will connect to the computer and charge using a usb wall outlet and I can listen to music, although it charges it doen’t fully charge I had it in for more than a day and it was still saying that it was charging. I can even record and listen to the radio, everything, I just can’t unplug it because it’ll turn off and won’t turn back on. I tried the soft power button (holding it on for 10 seconds and then letting go) it didn’t work. I can still listen to the music but what’s the point of having a portable music player if it’s not portable I can only use it when I’m at an outlet. I looked on the properties and it says it’s verion is v01.01.11A and the battery is 90%

I’m having the same problem. My sansa clip just cut off and I can’t turn it on at all. I connected it to my PC but it still doesn’t turn on. I bought it about 5 months ago. Can anybody help?

If you have a Sansa Clip that will respond while connected, the “Properties” option is only available if the Clip is in MTP mode.

Have a look at the device in Windows Explorer (My Computer, or use [Windows key] + E).  If the device shows up as a media player under Other , you can check charge status by right clicking on the device.  If the Clip is in MSC mode , it will show up under Devices   as a flash drive.  Properties will not be available.

If the device goes dead once disconnected, there is a problem with the battery connection.  Contact SanDisk technical support at 1-866-SANDISK for information regarding warranty replacement.

If communications under firmware version 1.01.11 is the issue, as MSC mode isn’t selectable on the device with the earliest firmware, all you need to do is update the firmwaer by following this thread: Firmware for Hardware Revision 1.0.

The battery in your Clip may have a broken connection.

The 8GB Clip has a different hardware layout.  For this version, the 2.0 Revision thread is your choice.

Bob  :smileyvery-happy:

Thank you all for your help

Unit was replaced.

Nothing else helped

Must say, though, Sansa customer support are fantastic.

Hi, I had the exact same thing happen to me ie no response from the Sansa either connected to my PC or not.  I remembered a reset method from another player manufacturer and decided to give it a shot.  I held down both the power button and the middle button on the Sansa at the same time for several seconds.  I wasn’t really paying attention to how long but probably somewhere between 10 to 30 seconds and what you know it started working again.