Why my SanDisk Portable SSD (exFAT format) doesn't work on my Mac? (SOLVED)

Hi mates, I just buy a SanDisk Extreme 1TB Portable SSD to store my files. By using a Windows PC, I copied my files from my old External HHD (NTFS format) to my new SanDisk Portable SSD (exFAT format).

After that, when I was checking the copied files on SDD by using Mac, I can not see the files. The SSD has been detected but I can’t see any files in it. I can see only the software install files. The SSD is also visible on Disk Utility and I can see almost the half of the disk is used. But the files that are using that storage is not visible on Finder. (check the screenshot below)

As I read, exFAT format should be working both Mac and Windows computers. I didn’t understand why this happening.

Do you have any idea why I can’t see my files?

I want to use this SSD on both my computers (Mac and Windows, but mostly on Mac). What is your suggestions for that?

Here is the answer that I found on Reddit;

“Do the names of your files/folders that you copied start with “.”? If so, those are hidden by default. You should remove that from the name and try connecting the drive to your Mac again to see if they’re visible then.
If still not visible or the above doesn’t apply, check if the Mac sees them as hidden files. Hit Command+Shift+”.” with the Finder window in focus and see if they appear then. If they do, you may want to unhide them to access them easier. You can do this in Windows if they’re hidden there through right clicking them and using Properties to unhide them.”

There are also some other helpful comments;

“Better to use HFS+, and get a free/freemium HFS+ driver on Windows. Or, if that option is not viable to you, you can format/erase the disk on Mac in ExFAT, which should fix the issue. Windows/factory format may have different cluster/sector sizes that Mac does not like.”

“exFAT formatted on Windows is not readable by MacOS. Found this out the hard way myself. Erase and format on Mac, and then it will work on both.”