White Screen?

I powered up my Sansa this morning, and the screen isn’t loadnig properly.  It’s completely white.  The music will play, but I can’t see anything.  Tried plugging it into the computer, same thing.  Help?

Have you tried re-setting it?

Reset the Fuze by sliding the power switch up to the spring loaded ON position, holding it there for 15 seconds, then release.  See if it starts up normally after that.

Bob  :dizzy_face:

Thanks for offering more detail, Bob. 

Sorry, would’ve expounded earlier on the procedure, but was typing one-handed. An english muffin with peanut butter on it was in the other.

Breakfast of Chanpions! :smileyvery-happy:

Yes, I tried doing that.  No luck. 


How’s this one for you?  I JUST FINISHED the exact same Breakfast of Champions.

With coffee, of course.

On to the Sansa in distress: If it’s playing, it sounds like a possible hardware issue with the display.  I would eliminate the software end of the equation by loading a new copy of the firmware manually.  This can be done from the PC without having to read the white display.

Follow the directions in the firmware thread.

Attempting to load the incorrect revision should not harm the device, it won’t load the alternate firmware.

I would then contact SanDisk at 1-866-SANDISK for a replacement.  If you just purchased the Fuze, you may be able to directly exchange it with your retailer.

Bob  :wink:


I have a 4GB Fuze, just updated to 1.01.22A firmware, and can duplicate this problem.

Just let the Fuze finish charging, and let the screen go dark. Since I can’t watch it all the time while it’s charging, I’ll come back in an hour or so. Then unplug it and the screen goes white.

Have to reset (hold the power switch for 6 seconds) to fix it.


Hi all:

I just got a Fuze 4 Gb. When  took it out of the box to charge it up, the screen is partially white with a black border on the left and very thin red, yellow and  blue strips on the right. I turn off the Fuze (the screen is black) I’ll let it charge for the night and then see if it work. If not, would that be a defective unit? 



I got the same problem too. White screen but its still playing. Tried resetting it and updated the firmware through my computer, and still no luck. Having replacement would be good, but it was just sent to me here in the Philippines, from my sister in the US. Now i gotta send the player to Us for replacement, and then have it sent again by my sister to me… :frowning: And that would cost me a lot i think…Wanna know if yours is already working properly. If so, what did you do? ( So that i dont have to send it anymore :() Thanks!

Message Edited by pmposadas on 12-24-2008 01:43 PM

Message Edited by pmposadas on 12-24-2008 01:43 PM


Bummer! Mine’s definately defetive so I’ll see if the Singapore branch can replace it. I contacted tech support in the meantime but I won’t hear from them until Janurary:cry:O well it happens


Message Edited by fuzeuser1 on 12-25-2008 07:17 AM


Contact the Phillipine distributor of Sandisk and see if they can replace your Fuze. The Singaporean distributor replaced today mine no questions asked. It was an obvious manufacturer’s defect. The new one works great :slight_smile:


unfortunately, there is no distributor of Sanza yet in the Philippines :frowning: Thanks for the advice anyway :smiley: